Skip to content
Laskyr

Plugins · gs-pinterest-portfolio · data as of 2026-11-04

Is GS Pinterest Portfolio safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.4)

As of 2026-11-04. 4 issues are on record for older versions; version 1.9.3 or newer fixes all of them that state a fix.

Latest version
1.9.4
Last updated
2026-11-03
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Show pins from any Pinterest profile or board on your site in a masonry grid, plus profile, board, pin and follow widgets. No API key. — by GS Plugins

What to do

  1. Update to the latest version (1.9.4). Anything older than 1.9.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gs-pinterest-portfolio --field=version shows what you run; wp plugin update gs-pinterest-portfolio updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-110370 · published 2026-10-21

PHP object injection in GS Pinterest Portfolio (1.9.2 and older)

Affected
1.9.2 and older
Fixed in
1.9.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in GS Plugins GS Pins for Pinterest gs-pinterest-portfolio allows Object Injection.This issue affects GS Pins for Pinterest: from n/a through 1.9.2.

NVD CVE-2026-110370Patchstack advisory

medium 5.4 CVE-2023-32593 · published 2024-12-13

Missing authorization check in GS Pinterest Portfolio (1.6.7 and older)

Affected
1.6.7 and older
Fixed in
1.6.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in GS Plugins GS Pins for Pinterest allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GS Pins for Pinterest: from n/a through 1.6.7.

NVD CVE-2023-32593Patchstack advisory

medium 5.4 CVE-2024-11453 · published 2024-12-03

Stored cross-site scripting (XSS) in GS Pinterest Portfolio (1.8.8 and older)

Affected
1.8.8 and older
Fixed in
1.8.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WordPress Pinterest Plugin – Make a Popup, User Profile, Masonry and Gallery Layout plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'gs_pin_widget' shortcode in all versions up to, and including, 1.8.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11453Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-30192 · published 2024-03-27

Stored cross-site scripting (XSS) in GS Pinterest Portfolio (1.8.2 and older)

Affected
1.8.2 and older
Fixed in
1.8.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GS Plugins GS Pins for Pinterest allows Stored XSS.This issue affects GS Pins for Pinterest: from n/a through 1.8.2.

NVD CVE-2024-30192Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GS Pinterest Portfolio vulnerability status badge
<a href="https://laskyr.com/plugins/gs-pinterest-portfolio"><img src="https://laskyr.com/plugins/gs-pinterest-portfolio/badge.svg" alt="GS Pinterest Portfolio vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit