Skip to content
Laskyr

Plugins · groups · data as of 2026-11-04

Is Groups safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.8.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.7.0 or newer fixes all of them that state a fix.

Latest version
4.8.0
Last updated
2026-09-24
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Turn your site into a powerful membership solution. Manage members, teams and access to content easily. — by itthinx

What to do

  1. Update to the latest version (4.8.0). Anything older than 4.7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get groups --field=version shows what you run; wp plugin update groups updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-77203 · published 2026-09-26

Privilege escalation in Groups (4.6.0 and older)

Affected
4.6.0 and older
Fixed in
4.7.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Groups – Memberships and Access Control plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 4.6.0. This is due to the groups_join() function deriving group-join eligibility from the ambient post's author capabilities via the global $post->post_author rather than from the currently authenticated user's own capabilities, while simultaneously minting and returning a valid groups-join-data hash and WordPress nonce for the caller in the same response — eliminating all authorization barriers to self-enrollment. This makes it possible for authenticated attackers, with Subscriber-level access and above, to enroll themselves into any group including privileged groups carrying the groups_admin_groups capability, and to subsequently create and join a group containing every registered WordPress capability, effectively escalating their privileges to Administrator. Exploitation requires the attacker to supply an Administrator-authored post ID via the post_ID parameter of the authenticated wp_ajax_parse_media_shortcode handler in order to establish the privileged ambient post context used by the flawed authorization check.

NVD CVE-2026-77203Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2026-0549 · published 2026-02-19

Stored cross-site scripting (XSS) in Groups (3.10.0 and older)

Affected
3.10.0 and older
Fixed in
3.11.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Groups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'groups_group_info' shortcode in all versions up to, and including, 3.10.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0549Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-11748 · published 2025-11-08

Missing authorization check in Groups (3.7.0 and older)

Affected
3.7.0 and older
Fixed in
3.8.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Groups plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 3.7.0 via the 'group_id' parameter of the group_join function due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to register for groups other than ones set in the shortcode.

NVD CVE-2025-11748Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Groups vulnerability status badge
<a href="https://laskyr.com/plugins/groups"><img src="https://laskyr.com/plugins/groups/badge.svg" alt="Groups vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit