Plugins · gridlist-view-for-woocommerce · data as of 2026-11-04
Is Grid/List View for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.0.10
- Last updated
- 2026-08-27
- Active installs
- 2,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Simple plugin for WooCommerce which toggle grid / list view of your products and toggle products count per page. — by BeRocket
What to do
- Update to the latest version (3.0.10). Anything older than 3.0.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gridlist-view-for-woocommerce --field=version shows what you run; wp plugin update gridlist-view-for-woocommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-15794 · published 2026-07-23
Stored cross-site scripting (XSS) in Grid/List View for WooCommerce (3.0.9 and older)
- Affected
- 3.0.9 and older
- Fixed in
- 3.0.9.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Grid/List View for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'position' Shortcode Attribute in all versions up to, and including, 3.0.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The shortcode's all_page="1" attribute can be used to force the widget to render on any page, expanding the attack surface beyond shop and category pages.
NVD CVE-2026-15794Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-27 — latest release on wordpress.org (3.0.10).
- 2026-07-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15794), fixed in 3.0.9.1.
Get an email when Grid/List View for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Grid/List View for WooCommerce (gridlist-view-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by BeRocket (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gridlist-view-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gridlist-view-for-woocommerce"><img src="https://laskyr.com/plugins/gridlist-view-for-woocommerce/badge.svg" alt="Grid/List View for WooCommerce vulnerability status"></a>