Skip to content
Laskyr

Plugins · grand-media · data as of 2026-11-04

Is Gmedia Photo Gallery safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.25.2)

As of 2026-11-04. 5 issues are on record for older versions; version 1.25.2 or newer fixes all of them that state a fix.

Latest version
1.25.2
Last updated
2026-10-14
Active installs
7,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Gmedia Gallery - photo gallery with comments, show EXIF & Metadata, gallery with map geolocation (GPS), private galleries. — by Serhii Pasyuk

What to do

  1. Update to the latest version (1.25.2). Anything older than 1.25.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get grand-media --field=version shows what you run; wp plugin update grand-media updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-96661 · published 2026-10-14

SQL injection in Gmedia Photo Gallery (1.25.1 and older)

Affected
1.25.1 and older
Fixed in
1.25.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gmedia Photo Gallery plugin for WordPress is vulnerable to time-based SQL Injection via the 'gmedia__in' parameter in all versions up to, and including, 1.25.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The unauthenticated mobile app endpoint dispatches the library action without validating the Mobile App feature flag, a nonce, or any WordPress authentication, meaning no account or session of any kind is required to exploit this vulnerability.

NVD CVE-2026-96661Wordfence advisoryPlugin source

critical 9.3 CVE-2026-39785 · published 2026-10-06

SQL injection in Gmedia Photo Gallery (1.25.1 and older)

Affected
1.25.1 and older
Fixed in
1.25.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Serhii Pasyuk Gmedia Photo Gallery grand-media allows Blind SQL Injection.This issue affects Gmedia Photo Gallery: from n/a through 1.25.1.

NVD CVE-2026-39785Patchstack advisory

medium 4.3 CVE-2025-63014 · published 2025-12-31

Cross-site request forgery (CSRF) in Gmedia Photo Gallery (1.25.0 and older)

Affected
1.25.0 and older
Fixed in
1.25.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Serhii Pasyuk Gmedia Photo Gallery grand-media allows Cross Site Request Forgery.This issue affects Gmedia Photo Gallery: from n/a through <= 1.25.0.

NVD CVE-2025-63014Patchstack advisory

high 7.5 CVE-2025-53257 · published 2025-06-27

File inclusion in Gmedia Photo Gallery (1.23.0 and older)

Affected
1.23.0 and older
Fixed in
1.24.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Serhii Pasyuk Gmedia Photo Gallery grand-media allows PHP Local File Inclusion.This issue affects Gmedia Photo Gallery: from n/a through <= 1.23.0.

NVD CVE-2025-53257Patchstack advisory

medium 4.8 CVE-2022-0873 · published 2022-05-16

Cross-site scripting (XSS) in Gmedia Photo Gallery (older than 1.20.0)

Affected
older than 1.20.0
Fixed in
1.20.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Gmedia Photo Gallery WordPress plugin before 1.20.0 does not sanitise and escape the Album's name before outputting it in pages/posts with a media embed, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered-html capability is disallowed

NVD CVE-2022-0873WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gmedia Photo Gallery vulnerability status badge
<a href="https://laskyr.com/plugins/grand-media"><img src="https://laskyr.com/plugins/grand-media/badge.svg" alt="Gmedia Photo Gallery vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit