Skip to content
Laskyr

Plugins · gotham-block-extra-light · data as of 2026-11-04

Is Gotham Block Extra Light safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.0)

As of 2026-11-04. 2 issues are on record for older versions.

Latest version
1.6.0
Last updated
2026-08-20
Active installs
30+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.0+

This plugin detects if the user's browser has AdBlock software activated and displays a popup if this is the case (screenshot 1). — by Kapsule Corp

What to do

  1. Update to the latest version (1.6.0). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gotham-block-extra-light --field=version shows what you run; wp plugin update gotham-block-extra-light updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-15020 · published 2026-01-14

Path traversal / file read in Gotham Block Extra Light (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gotham Block Extra Light plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to, and including, 1.5.0 via the 'ghostban' shortcode. This makes it possible for authenticated attackers, with contributor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2025-15020Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2025-15021 · published 2026-01-14

Stored cross-site scripting (XSS) in Gotham Block Extra Light (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gotham Block Extra Light plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-15021Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gotham Block Extra Light vulnerability status badge
<a href="https://laskyr.com/plugins/gotham-block-extra-light"><img src="https://laskyr.com/plugins/gotham-block-extra-light/badge.svg" alt="Gotham Block Extra Light vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit