Skip to content
Laskyr

Plugins · gopay-gateway · data as of 2026-11-04

Is GoPay for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.37)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.37 or newer fixes all of them that state a fix.

Latest version
1.0.37
Last updated
2026-10-21
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

WooCommerce and GoPay payment gateway integration — by gopayplugins

What to do

  1. Update to the latest version (1.0.37). Anything older than 1.0.37 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gopay-gateway --field=version shows what you run; wp plugin update gopay-gateway updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-75959 · published 2026-09-19

SQL injection in GoPay for WooCommerce (1.0.36 and older)

Affected
1.0.36 and older
Fixed in
1.0.37 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GoPay for WooCommerce plugin for WordPress is vulnerable to generic SQL Injection via the 'log_table_filter' parameter in all versions up to, and including, 1.0.36 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with shop manager-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-75959Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GoPay for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/gopay-gateway"><img src="https://laskyr.com/plugins/gopay-gateway/badge.svg" alt="GoPay for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit