Skip to content
Laskyr

Plugins · google-sitemap-generator · data as of 2026-11-01

Is XML Sitemap Generator for Google safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.25)

As of 2026-11-01. 3 issues are on record for older versions; version 4.1.23 or newer fixes all of them that state a fix.

Latest version
4.1.25
Last updated
2026-09-18
Active installs
1+ million
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.0+

Generate multiple types of sitemaps to improve SEO and get your website indexed quickly. — by Auctollo

What to do

  1. Update to the latest version (4.1.25). Anything older than 4.1.23 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get google-sitemap-generator --field=version shows what you run; wp plugin update google-sitemap-generator updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-64632 · published 2025-12-16

Missing authorization check in XML Sitemap Generator for Google (4.1.22 and older)

Affected
4.1.22 and older
Fixed in
4.1.23
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Auctollo Google XML Sitemaps google-sitemap-generator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Google XML Sitemaps: from n/a through <= 4.1.22.

NVD CVE-2025-64632Patchstack advisory

medium 6.1 CVE-2022-0346 · published 2022-05-23

Cross-site scripting (XSS) in XML Sitemap Generator for Google (older than 2.0.4)

Affected
older than 2.0.4
Fixed in
2.0.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The XML Sitemap Generator for Google WordPress plugin before 2.0.4 does not validate a parameter which can be set to an arbitrary value, thus causing XSS via error message or RCE if allow_url_include is turned on.

NVD CVE-2022-0346WPScan advisory

medium 4.8 CVE-2018-16204 · published 2019-01-09

Cross-site scripting (XSS) in XML Sitemap Generator for Google (4.0.9 and older)

Affected
4.0.9 and older
Fixed in
4.1.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

Cross-site scripting vulnerability in Google XML Sitemaps Version 4.0.9 and earlier allows remote authenticated attackers to inject arbitrary web script or HTML via unspecified vectors.

NVD CVE-2018-16204wordpress.orgjvn.jp

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
XML Sitemap Generator for Google vulnerability status badge
<a href="https://laskyr.com/plugins/google-sitemap-generator"><img src="https://laskyr.com/plugins/google-sitemap-generator/badge.svg" alt="XML Sitemap Generator for Google vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit