Skip to content
Laskyr

Plugins · google-site-kit · data as of 2026-11-01

Is Site Kit by Google safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.190.0)

As of 2026-11-01. 3 issues are on record for older versions; version 1.187.0 or newer fixes all of them that state a fix.

Latest version
1.190.0
Last updated
2026-10-19
Active installs
5+ million
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Site Kit is a one-stop solution for WordPress users to use everything Google has to offer to make them successful on the web. — by Google

What to do

  1. Update to the latest version (1.190.0). Anything older than 1.187.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get google-site-kit --field=version shows what you run; wp plugin update google-site-kit updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-62139 · published 2026-09-11

Cross-site request forgery (CSRF) in Site Kit by Google (1.186.0 and older)

Affected
1.186.0 and older
Fixed in
1.187.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Site Kit by Google <= 1.186.0 versions.

NVD CVE-2026-62139Patchstack advisory

low 2.7 CVE-2026-10753 · published 2026-06-24

Security issue in Site Kit by Google (older than 1.176.0)

Affected
older than 1.176.0
Fixed in
1.176.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Site Kit by Google WordPress plugin before 1.176.0 does not properly restrict a REST API write endpoint to administrators, allowing lower-privileged users who have been granted dashboard sharing access (such as Editors) to modify a site-wide Site Kit by Google WordPress plugin before 1.176.0 setting that should only be modifiable by administrators.

NVD CVE-2026-10753WPScan advisory

medium 4.3 CVE-2020-8934 · published 2023-07-07

Information disclosure in Site Kit by Google (1.8.0 and older)

Affected
1.8.0 and older
Fixed in
1.8.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.8.0 This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console. We recommend upgrading to V1.8.1 or above.

NVD CVE-2020-8934Wordfence advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Site Kit by Google vulnerability status badge
<a href="https://laskyr.com/plugins/google-site-kit"><img src="https://laskyr.com/plugins/google-site-kit/badge.svg" alt="Site Kit by Google vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit