Skip to content
Laskyr

Plugins · google-maps-easy · data as of 2026-11-04

Is Easy Google Maps by Supsystic safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.16.1)

As of 2026-11-04. 9 issues are on record for older versions; version 1.15.1 or newer fixes all of them that state a fix.

Latest version
1.16.1
Last updated
2026-10-30
Active installs
20,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Google Maps with unlimited markers, custom icons, marker categories, clustering and map themes. Gutenberg block, Elementor widget, no coding. — by supsystic

What to do

  1. Update to the latest version (1.16.1). Anything older than 1.15.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get google-maps-easy --field=version shows what you run; wp plugin update google-maps-easy updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-102395 · published 2026-09-30

Cross-site scripting (XSS) in Easy Google Maps by Supsystic (1.14.6 and older)

Affected
1.14.6 and older
Fixed in
1.15.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Easy Google Maps <= 1.14.6 versions.

NVD CVE-2026-102395Patchstack advisory

high 7.2 CVE-2026-73367 · published 2026-08-18

File inclusion in Easy Google Maps by Supsystic (older than 1.14.2)

Affected
older than 1.14.2
Fixed in
1.14.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Remote File Inclusion in Easy Google Maps < 1.14.2 versions.

NVD CVE-2026-73367Patchstack advisory

critical 9.8 CVE-2026-73366 · published 2026-08-18

PHP object injection in Easy Google Maps by Supsystic (1.13.0 and older)

Affected
1.13.0 and older
Fixed in
1.14.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in Easy Google Maps <= 1.13.0 versions.

NVD CVE-2026-73366Patchstack advisory

medium 6.6 CVE-2025-32138 · published 2025-04-04

Security issue in Easy Google Maps by Supsystic (1.11.18 and older)

Affected
1.11.18 and older
Fixed in
1.11.19
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Restriction of XML External Entity Reference vulnerability in supsystic Easy Google Maps google-maps-easy allows XML Injection.This issue affects Easy Google Maps: from n/a through <= 1.11.18.

NVD CVE-2025-32138Patchstack advisory

medium 5.4 CVE-2024-5219 · published 2024-07-02

Stored cross-site scripting (XSS) in Easy Google Maps by Supsystic (1.11.15 and older)

Affected
1.11.15 and older
Fixed in
1.11.16 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Easy Google Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file upload feature in all versions up to, and including, 1.11.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5219Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-31269 · published 2024-04-12

Cross-site request forgery (CSRF) in Easy Google Maps by Supsystic (1.11.11 and older)

Affected
1.11.11 and older
Fixed in
1.11.12
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Supsystic Easy Google Maps.This issue affects Easy Google Maps: from n/a through 1.11.11.

NVD CVE-2024-31269Patchstack advisory

medium 5.4 CVE-2023-2526 · published 2023-06-09

Cross-site request forgery (CSRF) in Easy Google Maps by Supsystic (1.11.7 and older)

Affected
1.11.7 and older
Fixed in
1.11.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Easy Google Maps plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.11.7. This is due to missing or incorrect nonce validation on the AJAX action handler. This makes it possible for unauthenticated attackers to executes AJAX actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. CVE-2024-31269 appears to be a duplicate of this issue.

NVD CVE-2023-2526Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2023-33926 · published 2023-05-28

Cross-site request forgery (CSRF) in Easy Google Maps by Supsystic (1.11.7 and older)

Affected
1.11.7 and older
Fixed in
1.11.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Supsystic Easy Google Maps plugin <= 1.11.7 versions.

NVD CVE-2023-33926Patchstack advisory

medium 4.8 CVE-2021-39346 · published 2021-11-01

Stored cross-site scripting (XSS) in Easy Google Maps by Supsystic (1.9.33 to 1.9.33)

Affected
1.9.33 to 1.9.33
Fixed in
1.10.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Google Maps Easy WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.9.33. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.

NVD CVE-2021-39346Code change (fix)github.comWordfence advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Google Maps by Supsystic vulnerability status badge
<a href="https://laskyr.com/plugins/google-maps-easy"><img src="https://laskyr.com/plugins/google-maps-easy/badge.svg" alt="Easy Google Maps by Supsystic vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit