Plugins · google-listings-and-ads · data as of 2026-11-01
Is Google for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.10.0
- Last updated
- 2026-10-20
- Active installs
- 800,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Native integration with Google that allows merchants to easily display their products across Google’s network. — by WooCommerce
What to do
- Update to the latest version (3.10.0). Anything older than 2.8.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get google-listings-and-ads --field=version shows what you run; wp plugin update google-listings-and-ads updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2024-10486 · published 2024-11-18
Information disclosure in Google for WooCommerce (2.8.6 and older)
- Affected
- 2.8.6 and older
- Fixed in
- 2.8.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Google for WooCommerce plugin for WordPress is vulnerable to Information Disclosure in all versions up to, and including, 2.8.6. This is due to publicly accessible print_php_information.php file. This makes it possible for unauthenticated attackers to retrieve information about Webserver and PHP configuration, which can be used to aid other attacks.
Recent activity
- 2026-10-20 — latest release on wordpress.org (3.10.0).
- 2024-11-18 — Information disclosure disclosed (CVE-2024-10486), fixed in 2.8.7.
Get an email when Google for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Google for WooCommerce (google-listings-and-ads) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/google-listings-and-ads (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/google-listings-and-ads"><img src="https://laskyr.com/plugins/google-listings-and-ads/badge.svg" alt="Google for WooCommerce vulnerability status"></a>