Plugins · google-distance-calculator · data as of 2026-11-04
Is MK Google Directions safe? Known vulnerabilities and latest version
- Latest version
- 3.1.1
- Last updated
- 2025-02-25
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.7.11
Enable use of Google Directions in your WordPress blog. — by Manoj Kumar
What to do
- There is no fixed version yet. If you can live without MK Google Directions for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get google-distance-calculator --field=version shows what you run; wp plugin update google-distance-calculator updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 3.1.1 CVE-2026-39674 · published 2026-04-08
Cross-site scripting (XSS) in MK Google Directions (3.1.1 and older)
- Affected
- 3.1.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Manoj Kumar MK Google Directions google-distance-calculator allows DOM-Based XSS.This issue affects MK Google Directions: from n/a through <= 3.1.1.
medium 5.4 CVE-2024-12820 · published 2025-02-28
Stored cross-site scripting (XSS) in MK Google Directions (3.1 and older)
- Affected
- 3.1 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The MK Google Directions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'MKGD' shortcode in all versions up to, and including, 3.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2025-02-25 — latest release on wordpress.org (3.1.1).
- 2026-04-08 — Cross-site scripting (XSS) disclosed (CVE-2026-39674), no fix listed yet.
- 2025-02-28 — Stored cross-site scripting (XSS) disclosed (CVE-2024-12820), fixed in 3.1.1.
Get an email when MK Google Directions has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MK Google Directions (google-distance-calculator) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/google-distance-calculator (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/google-distance-calculator"><img src="https://laskyr.com/plugins/google-distance-calculator/badge.svg" alt="MK Google Directions vulnerability status"></a>