Skip to content
Laskyr

Plugins · google-calendar-events · data as of 2026-11-04

Is Simple Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.3.1)

As of 2026-11-04. 5 issues are on record for older versions; version 3.6.0 or newer fixes all of them that state a fix.

Latest version
4.3.1
Last updated
2026-10-07
Active installs
50,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.1+

Add Google Calendar events to your WordPress site in minutes. Beautiful calendar displays. Mobile responsive. — by SimpleCalendar

What to do

  1. Update to the latest version (4.3.1). Anything older than 3.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get google-calendar-events --field=version shows what you run; wp plugin update google-calendar-events updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-68979 · published 2025-12-30

Missing authorization check in Simple Calendar (3.5.9 and older)

Affected
3.5.9 and older
Fixed in
3.6.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in SimpleCalendar Google Calendar Events google-calendar-events allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Google Calendar Events: from n/a through <= 3.5.9.

NVD CVE-2025-68979Patchstack advisory

medium 6.1 CVE-2024-8549 · published 2024-09-25

Reflected cross-site scripting (XSS) in Simple Calendar (3.4.2 and older)

Affected
3.4.2 and older
Fixed in
3.4.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Simple Calendar – Google Calendar Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.4.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-8549Wordfence advisoryCode change (fix)

medium 5.4 CVE-2023-49151 · published 2023-12-14

Stored cross-site scripting (XSS) in Simple Calendar (3.2.6 and older)

Affected
3.2.6 and older
Fixed in
3.2.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Simple Calendar Simple Calendar – Google Calendar Plugin allows Stored XSS.This issue affects Simple Calendar – Google Calendar Plugin: from n/a through 3.2.6.

NVD CVE-2023-49151Patchstack advisory

high 8.8 CVE-2023-46189 · published 2023-10-25

Cross-site request forgery (CSRF) in Simple Calendar (3.2.5 and older)

Affected
3.2.5 and older
Fixed in
3.2.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Simple Calendar – Google Calendar Plugin <= 3.2.5 versions.

NVD CVE-2023-46189Patchstack advisory

medium 4.3 CVE-2014-7138 · published 2014-10-16

Cross-site scripting (XSS) in Simple Calendar (2.0.3.1 and older)

Affected
2.0.3.1 and older
Fixed in
2.0.4 *
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site scripting (XSS) vulnerability in the Google Calendar Events plugin before 2.0.4 for WordPress allows remote attackers to inject arbitrary web script or HTML via the gce_feed_ids parameter in a gce_ajax action to wp-admin/admin-ajax.php.

NVD CVE-2014-7138wordpress.orgpacketstormsecurity.comsecurityfocus.comsecurityfocus.comexchange.xforce.ibmcloud.comgithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/google-calendar-events"><img src="https://laskyr.com/plugins/google-calendar-events/badge.svg" alt="Simple Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit