Skip to content
Laskyr

Plugins · goodmeet · data as of 2026-11-04

Is GoodMeet safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.3)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.9 or newer fixes all of them that state a fix.

Latest version
2.2.3
Last updated
2026-11-01
Active installs
70+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Create Google Meet meetings from WordPress, each with a Google Calendar event and a meeting page your visitors join from. — by Sovlix

What to do

  1. Update to the latest version (2.2.3). Anything older than 1.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get goodmeet --field=version shows what you run; wp plugin update goodmeet updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-6440 · published 2026-07-10

Cross-site request forgery (CSRF) in GoodMeet (1.1.8 and older)

Affected
1.1.8 and older
Fixed in
1.1.9 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GoodMeet – Google Meet Integration for Webinar, Meeting & Video Conference plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to and including 1.1.8. This is due to a missing nonce verification in the reset_credential() function, which handles the wp_ajax_goodmeet_reset_google_meet_credential AJAX action. While the function does verify the user's capability (manage_options), it does not validate a nonce, making it susceptible to CSRF attacks. This makes it possible for unauthenticated attackers to trick a site administrator into clicking a malicious link that will reset (delete) the plugin's stored Google Meet API credentials (goodmeet_google_credentials) and OAuth tokens (goodmeet_google_token), effectively disabling the Google Meet integration on the site.

NVD CVE-2026-6440Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GoodMeet vulnerability status badge
<a href="https://laskyr.com/plugins/goodmeet"><img src="https://laskyr.com/plugins/goodmeet/badge.svg" alt="GoodMeet vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit