Skip to content
Laskyr

Plugins · gmap-targeting · data as of 2026-11-04

Is GMap Targeting safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.8)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.8 or newer fixes all of them that state a fix.

Latest version
1.1.8
Last updated
2025-12-05
Active installs
60+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Set Google Map everywhere by shortcode on your WordPress site simply. One click - one map! This lightweight plugin is managed in an intuitive way. — by RealMag777

What to do

  1. Update to the latest version (1.1.8). Anything older than 1.1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gmap-targeting --field=version shows what you run; wp plugin update gmap-targeting updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2025-67990 · published 2026-02-20

Reflected cross-site scripting (XSS) in GMap Targeting (1.1.7 and older)

Affected
1.1.7 and older
Fixed in
1.1.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in RealMag777 GMap Targeting gmap-targeting allows Reflected XSS.This issue affects GMap Targeting: from n/a through <= 1.1.7.

NVD CVE-2025-67990Patchstack advisory

high 8.8 CVE-2025-52732 · published 2025-08-14

File inclusion in GMap Targeting (1.1.6 and older)

Affected
1.1.6 and older
Fixed in
1.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in RealMag777 GMap Targeting gmap-targeting allows PHP Local File Inclusion.This issue affects GMap Targeting: from n/a through <= 1.1.6.

NVD CVE-2025-52732Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GMap Targeting vulnerability status badge
<a href="https://laskyr.com/plugins/gmap-targeting"><img src="https://laskyr.com/plugins/gmap-targeting/badge.svg" alt="GMap Targeting vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit