Plugins · gmail-smtp · data as of 2026-11-04
Is Gmail SMTP safe? Known vulnerabilities and latest version
- Latest version
- 1.2.3.23
- Last updated
- 2026-11-01
- Active installs
- 10,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
Connect to Gmail SMTP server to automatically send email from your WordPress site. Configure wp_mail() to use SMTP with OAuth 2.0 authentication. — by Noor Alam
What to do
- Update to the latest version (1.2.3.23). Anything older than 1.2.3.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gmail-smtp --field=version shows what you run; wp plugin update gmail-smtp updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-57657 · published 2026-06-26
Cross-site request forgery (CSRF) in Gmail SMTP (1.2.3.19 and older)
- Affected
- 1.2.3.19 and older
- Fixed in
- 1.2.3.20
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Request Forgery (CSRF) in Gmail SMTP <= 1.2.3.19 versions.
Recent activity
- 2026-11-01 — latest release on wordpress.org (1.2.3.23).
- 2026-06-26 — Cross-site request forgery (CSRF) disclosed (CVE-2026-57657), fixed in 1.2.3.20.
Get an email when Gmail SMTP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gmail SMTP (gmail-smtp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Noor Alam (5 tracked)
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gmail-smtp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gmail-smtp"><img src="https://laskyr.com/plugins/gmail-smtp/badge.svg" alt="Gmail SMTP vulnerability status"></a>