Plugins · global-payments-woocommerce · data as of 2026-11-04
Is GlobalPayments Gateway Provider for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 1.23.3
- Last updated
- 2026-10-22
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 7.1.4 · PHP 8.2+
This extension allows WooCommerce to use the available Global Payments payment gateways. All card data is tokenized using the respective gateway' … — by Global Payments
What to do
- There is no fixed version yet. If you can live without GlobalPayments Gateway Provider for WooCommerce for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get global-payments-woocommerce --field=version shows what you run; wp plugin update global-payments-woocommerce updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 1.23.3 CVE-2026-118085 · published 2026-10-29
Cross-site scripting (XSS) in GlobalPayments Gateway Provider for WooCommerce (1.23.3 and older)
- Affected
- 1.23.3 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in GlobalPayments WooCommerce <= 1.23.3 versions.
medium 5.4 CVE-2026-39645 · published 2026-04-08
Server-side request forgery (SSRF) in GlobalPayments Gateway Provider for WooCommerce (1.18.0 and older)
- Affected
- 1.18.0 and older
- Fixed in
- 1.18.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Global Payments GlobalPayments WooCommerce global-payments-woocommerce allows Server Side Request Forgery.This issue affects GlobalPayments WooCommerce: from n/a through <= 1.18.0.
high 7.1 CVE-2025-22767 · published 2025-03-28
Reflected cross-site scripting (XSS) in GlobalPayments Gateway Provider for WooCommerce (1.13.2 and older)
- Affected
- 1.13.2 and older
- Fixed in
- 1.13.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Global Payments GlobalPayments WooCommerce global-payments-woocommerce allows Reflected XSS.This issue affects GlobalPayments WooCommerce: from n/a through <= 1.13.2.
Recent activity
- 2026-10-22 — latest release on wordpress.org (1.23.3).
- 2026-10-29 — Cross-site scripting (XSS) disclosed (CVE-2026-118085), no fix listed yet.
- 2026-04-08 — Server-side request forgery (SSRF) disclosed (CVE-2026-39645), fixed in 1.18.1.
- 2025-03-28 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-22767), fixed in 1.13.3.
Get an email when GlobalPayments Gateway Provider for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for GlobalPayments Gateway Provider for WooCommerce (global-payments-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/global-payments-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/global-payments-woocommerce"><img src="https://laskyr.com/plugins/global-payments-woocommerce/badge.svg" alt="GlobalPayments Gateway Provider for WooCommerce vulnerability status"></a>