Skip to content
Laskyr

Plugins · gift4u-gift-cards-all-in-one-for-woo · data as of 2026-11-04

Is GIFT4U safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.4)

As of 2026-11-04. 3 issues are on record for older versions; version 1.1.4 or newer fixes all of them that state a fix.

Latest version
1.1.4
Last updated
2026-10-08
Active installs
200+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Attract customers by unlocking the potential of gift card products. Easily create, sell, and manage a WooCommerce gift card with a few simple steps. — by VillaTheme

What to do

  1. Update to the latest version (1.1.4). Anything older than 1.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gift4u-gift-cards-all-in-one-for-woo --field=version shows what you run; wp plugin update gift4u-gift-cards-all-in-one-for-woo updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.9 CVE-2026-103357 · published 2026-10-10

Missing authorization check in GIFT4U (1.1.3 and older)

Affected
1.1.3 and older
Fixed in
1.1.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in VillaTheme GIFT4U gift4u-gift-cards-all-in-one-for-woo allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GIFT4U: from n/a through 1.1.3.

NVD CVE-2026-103357Patchstack advisory

medium 6.5 CVE-2026-57324 · published 2026-06-26

Missing authorization check in GIFT4U (1.0.10 and older)

Affected
1.0.10 and older
Fixed in
1.1.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in GIFT4U <= 1.0.10 versions.

NVD CVE-2026-57324Patchstack advisory

critical 9.3 CVE-2026-54809 · published 2026-06-17

SQL injection in GIFT4U (1.0.10 and older)

Affected
1.0.10 and older
Fixed in
1.1.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in VillaTheme GIFT4U allows Blind SQL Injection. This issue affects GIFT4U: from n/a through 1.0.10.

NVD CVE-2026-54809Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GIFT4U vulnerability status badge
<a href="https://laskyr.com/plugins/gift4u-gift-cards-all-in-one-for-woo"><img src="https://laskyr.com/plugins/gift4u-gift-cards-all-in-one-for-woo/badge.svg" alt="GIFT4U vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit