Plugins · gift-voucher · data as of 2026-11-04
Is Gift Cards (Gift Vouchers and Packages) (WooCo… safe? Known vulnerabilities and latest version
- Latest version
- 4.9.1
- Last updated
- 2026-11-02
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Sell gift cards, gift vouchers and gift packages on your WordPress site. Customers design the card, pay online and receive a PDF by email. — by Codemenschen
What to do
- Update to the latest version (4.9.1). Anything older than 4.7.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gift-voucher --field=version shows what you run; wp plugin update gift-voucher updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-57415 · published 2026-07-13
Stored cross-site scripting (XSS) in Gift Cards (Gift Vouchers and Packages) (WooCo… (4.7.0 and older)
- Affected
- 4.7.0 and older
- Fixed in
- 4.7.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Codemenschen Gift Vouchers gift-voucher allows Stored XSS.This issue affects Gift Vouchers: from n/a through <= 4.7.0.
medium 6.5 CVE-2026-57412 · published 2026-07-13
Missing authorization check in Gift Cards (Gift Vouchers and Packages) (WooCo… (4.6.9 and older)
- Affected
- 4.6.9 and older
- Fixed in
- 4.7.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Codemenschen Gift Vouchers gift-voucher allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Gift Vouchers: from n/a through <= 4.6.9.
medium 5.3 CVE-2024-13520 · published 2025-02-20
Missing authorization check in Gift Cards (Gift Vouchers and Packages) (WooCo… (4.4.9 and older)
- Affected
- 4.4.9 and older
- Fixed in
- 4.5.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) plugin for WordPress is vulnerable to unauthorized modification of data|loss of data due to a missing capability check on the 'update_voucher_price', 'update_voucher_date', 'update_voucher_note' functions in all versions up to, and including, 4.4.9. This makes it possible for unauthenticated attackers to update the value, expiration date, and user note for any gift voucher.
medium 6.4 CVE-2024-9165 · published 2024-10-31
Stored cross-site scripting (XSS) in Gift Cards (Gift Vouchers and Packages) (WooCo… (4.4.4 and older)
- Affected
- 4.4.4 and older
- Fixed in
- 4.4.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Gift Cards (Gift Vouchers and Packages) (WooCommerce Supported) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 4.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2024-9165Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 4.3 CVE-2024-32436 · published 2024-04-15
Cross-site request forgery (CSRF) in Gift Cards (Gift Vouchers and Packages) (WooCo… (4.4.0 and older)
- Affected
- 4.4.0 and older
- Fixed in
- 4.4.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Codemenschen Gift Vouchers.This issue affects Gift Vouchers: from n/a through 4.4.0.
Recent activity
- 2026-11-02 — latest release on wordpress.org (4.9.1).
- 2026-07-13 — Stored cross-site scripting (XSS) disclosed (CVE-2026-57415), fixed in 4.7.1.
- 2026-07-13 — Missing authorization check disclosed (CVE-2026-57412), fixed in 4.7.0.
- 2025-02-20 — Missing authorization check disclosed (CVE-2024-13520), fixed in 4.5.0.
Get an email when Gift Cards (Gift Vouchers and Packages) (WooCo… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gift Cards (Gift Vouchers and Packages) (WooCo… (gift-voucher) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gift-voucher (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gift-voucher"><img src="https://laskyr.com/plugins/gift-voucher/badge.svg" alt="Gift Cards (Gift Vouchers and Packages) (WooCo… vulnerability status"></a>