Plugins · gift-up · data as of 2026-11-04
Is Gift Up Gift Cards for WordPress and WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.3.1
- Last updated
- 2026-10-07
- Active installs
- 5,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
The simplest way to sell gift cards online. Sell your own gift cards, gift certificates and gift vouchers from inside your WordPress website easily wi … — by Gift Up!
What to do
- Update to the latest version (3.3.1). Anything older than 3.1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gift-up --field=version shows what you run; wp plugin update gift-up updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-32412 · published 2026-03-13
Server-side request forgery (SSRF) in Gift Up Gift Cards for WordPress and WooCommerce (3.1.7 and older)
- Affected
- 3.1.7 and older
- Fixed in
- 3.1.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Gift Up! Gift Up Gift Cards for WordPress and WooCommerce gift-up allows Server Side Request Forgery.This issue affects Gift Up Gift Cards for WordPress and WooCommerce: from n/a through <= 3.1.7.
high 8.8 CVE-2023-49744 · published 2023-12-15
Cross-site request forgery (CSRF) in Gift Up Gift Cards for WordPress and WooCommerce (2.21.3 and older)
- Affected
- 2.21.3 and older
- Fixed in
- 2.22
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Gift Up Gift Up Gift Cards for WordPress and WooCommerce.This issue affects Gift Up Gift Cards for WordPress and WooCommerce: from n/a through 2.21.3.
medium 5.4 CVE-2023-5703 · published 2023-11-07
Stored cross-site scripting (XSS) in Gift Up Gift Cards for WordPress and WooCommerce (2.20.1 and older)
- Affected
- 2.20.1 and older
- Fixed in
- 2.20.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Gift Up Gift Cards for WordPress and WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'giftup' shortcode in all versions up to, and including, 2.20.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2023-5703Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-07 — latest release on wordpress.org (3.3.1).
- 2026-03-13 — Server-side request forgery (SSRF) disclosed (CVE-2026-32412), fixed in 3.1.8.
- 2023-12-15 — Cross-site request forgery (CSRF) disclosed (CVE-2023-49744), fixed in 2.22.
- 2023-11-07 — Stored cross-site scripting (XSS) disclosed (CVE-2023-5703), fixed in 2.20.2.
Get an email when Gift Up Gift Cards for WordPress and WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gift Up Gift Cards for WordPress and WooCommerce (gift-up) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Server-side request forgery (SSRF) (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gift-up (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gift-up"><img src="https://laskyr.com/plugins/gift-up/badge.svg" alt="Gift Up Gift Cards for WordPress and WooCommerce vulnerability status"></a>