Skip to content
Laskyr

Plugins · ghostkit · data as of 2026-11-04

Is Block Animations, Motion & Scroll Effects safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.8.0)

As of 2026-11-04. 3 issues are on record for older versions; version 3.6.1 or newer fixes all of them that state a fix.

Latest version
3.8.0
Last updated
2026-10-24
Active installs
6,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.2 · PHP 8.3+

Animate WordPress blocks with reveal, scroll, mouse and loop effects, set in the block settings. — by nK

What to do

  1. Update to the latest version (3.8.0). Anything older than 3.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ghostkit --field=version shows what you run; wp plugin update ghostkit updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-57651 · published 2026-06-26

Cross-site scripting (XSS) in Block Animations, Motion & Scroll Effects (3.6.0 and older)

Affected
3.6.0 and older
Fixed in
3.6.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Ghost Kit <= 3.6.0 versions.

NVD CVE-2026-57651Patchstack advisory

medium 6.4 CVE-2025-9992 · published 2025-09-18

Stored cross-site scripting (XSS) in Block Animations, Motion & Scroll Effects (3.4.3 and older)

Affected
3.4.3 and older
Fixed in
3.4.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Ghost Kit – Page Builder Blocks, Motion Effects & Extensions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the custom JS field in all versions up to, and including, 3.4.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9992Wordfence advisoryCode change (fix)

high 8.1 CVE-2025-53567 · published 2025-08-20

File inclusion in Block Animations, Motion & Scroll Effects (3.4.1 and older)

Affected
3.4.1 and older
Fixed in
3.4.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in nK Ghost Kit ghostkit allows PHP Local File Inclusion.This issue affects Ghost Kit: from n/a through <= 3.4.1.

NVD CVE-2025-53567Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Block Animations, Motion & Scroll Effects vulnerability status badge
<a href="https://laskyr.com/plugins/ghostkit"><img src="https://laskyr.com/plugins/ghostkit/badge.svg" alt="Block Animations, Motion & Scroll Effects vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit