Skip to content
Laskyr

Plugins · gf-multi-uploader · data as of 2026-11-04

Is Multi Uploader for Gravity Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.11)

As of 2026-11-04. 4 issues are on record for older versions; version 1.1.10 or newer fixes all of them that state a fix.

Latest version
1.1.11
Last updated
2026-10-21
Active installs
10+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Chunked Multiple file uploads, from images, videos to pdf. Files stored in WP Media Library. — by sh1zen

What to do

  1. Update to the latest version (1.1.11). Anything older than 1.1.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gf-multi-uploader --field=version shows what you run; wp plugin update gf-multi-uploader updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-87796 · published 2026-09-17

Arbitrary file upload in Multi Uploader for Gravity Forms (1.1.9 and older)

Affected
1.1.9 and older
Fixed in
1.1.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Multi Uploader for Gravity Forms plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 1.1.9 via the move_file function. This is due to insufficient file type validation during chunked upload handling. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2026-87796Wordfence advisoryPlugin source

critical 9.1 CVE-2026-5581 · published 2026-08-05

Cross-site request forgery (CSRF) in Multi Uploader for Gravity Forms (1.1.8 and older)

Affected
1.1.8 and older
Fixed in
1.1.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Multi Uploader for Gravity Forms plugin for WordPress is vulnerable to unauthorized arbitrary media deletion in all versions up to, and including, 1.1.8. This is due to missing capability checks in the `plupload_ajax_delete_file()` function, which is registered via `wp_ajax_nopriv_gfmu_delete_file`. The nonce intended for CSRF protection is exposed on any public-facing page containing a multi-uploader form field via the `GFMU_options` JavaScript object. This makes it possible for unauthenticated attackers to permanently delete any WordPress media attachment by supplying its attachment ID, potentially leading to complete media library destruction.

NVD CVE-2026-5581Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2025-14344 · published 2025-12-12

Arbitrary file deletion in Multi Uploader for Gravity Forms (1.1.7 and older)

Affected
1.1.7 and older
Fixed in
1.1.10 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Multi Uploader for Gravity Forms plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'plupload_ajax_delete_file' function in all versions up to, and including, 1.1.7. This makes it possible for unauthenticated attackers to delete arbitrary files on the server.

NVD CVE-2025-14344Wordfence advisoryCode change (fix)Plugin source

critical 9.0 CVE-2025-23921 · published 2025-01-22

Arbitrary file upload in Multi Uploader for Gravity Forms (1.1.3 and older)

Affected
1.1.3 and older
Fixed in
1.1.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in sh1zen Multi Uploader for Gravity Forms gf-multi-uploader allows Upload a Web Shell to a Web Server.This issue affects Multi Uploader for Gravity Forms: from n/a through <= 1.1.3.

NVD CVE-2025-23921Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Multi Uploader for Gravity Forms vulnerability status badge
<a href="https://laskyr.com/plugins/gf-multi-uploader"><img src="https://laskyr.com/plugins/gf-multi-uploader/badge.svg" alt="Multi Uploader for Gravity Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit