Skip to content
Laskyr

Plugins · getgenie · data as of 2026-11-04

Is GetGenie safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5.6)

As of 2026-11-04. 7 issues are on record for older versions; version 4.5.0 or newer fixes all of them that state a fix.

Latest version
4.5.6
Last updated
2026-09-07
Active installs
70,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

AI powered SEO assistant & content writer with 40+ templates, chatbot, NLP keyword research, AEO, GEO, SEO analysis for WordPress, — by Roxnor

What to do

  1. Update to the latest version (4.5.6). Anything older than 4.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get getgenie --field=version shows what you run; wp plugin update getgenie updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-65440 · published 2026-07-27

Cross-site scripting (XSS) in GetGenie (4.4.3 and older)

Affected
4.4.3 and older
Fixed in
4.5.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in GetGenie <= 4.4.3 versions.

NVD CVE-2026-65440Patchstack advisory

medium 6.5 CVE-2026-57316 · published 2026-06-26

Information disclosure in GetGenie (4.4.2 and older)

Affected
4.4.2 and older
Fixed in
4.4.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in GetGenie <= 4.4.2 versions.

NVD CVE-2026-57316Patchstack advisory

medium 6.5 CVE-2026-54197 · published 2026-06-16

Information disclosure in GetGenie (4.4.1 and older)

Affected
4.4.1 and older
Fixed in
4.4.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in GetGenie <= 4.4.1 versions.

NVD CVE-2026-54197Patchstack advisory

medium 5.4 CVE-2026-2879 · published 2026-03-13

Missing authorization check in GetGenie (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GetGenie plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.3.2. This is due to missing validation on the `id` parameter in the `create()` method of the `GetGenieChat` REST API endpoint. The method accepts a user-controlled post ID and, when a post with that ID exists, calls `wp_update_post()` without verifying that the current user owns the post or that the post is of the expected `getgenie_chat` type. This makes it possible for authenticated attackers, with Author-level access and above, to overwrite arbitrary posts owned by any user — including Administrators — effectively destroying the original content by changing its `post_type` to `getgenie_chat` and reassigning `post_author` to the attacker.

NVD CVE-2026-2879Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2026-2257 · published 2026-03-13

Stored cross-site scripting (XSS) in GetGenie (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GetGenie plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 4.3.2 due to missing validation on a user controlled key in the `action` function. This makes it possible for authenticated attackers, with Author-level access and above, to update post metadata for arbitrary posts. Combined with a lack of input sanitization, this leads to Stored Cross-Site Scripting when a higher-privileged user (such as an Administrator) views the affected post's "Competitor" tab in the GetGenie sidebar.

NVD CVE-2026-2257Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2026-24356 · published 2026-01-22

Missing authorization check in GetGenie (4.3.0 and older)

Affected
4.3.0 and older
Fixed in
4.3.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Roxnor GetGenie getgenie allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GetGenie: from n/a through <= 4.3.0.

NVD CVE-2026-24356Patchstack advisory

medium 4.3 CVE-2026-1003 · published 2026-01-16

Missing authorization check in GetGenie (4.3.0 and older)

Affected
4.3.0 and older
Fixed in
4.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GetGenie plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.3.0. This is due to the plugin not properly verifying that a user is authorized to delete a specific post. This makes it possible for authenticated attackers, with Author-level access and above, to delete any post on the WordPress site, including posts authored by other users.

NVD CVE-2026-1003Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GetGenie vulnerability status badge
<a href="https://laskyr.com/plugins/getgenie"><img src="https://laskyr.com/plugins/getgenie/badge.svg" alt="GetGenie vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit