Skip to content
Laskyr

Plugins · genolve-toolkit · data as of 2026-11-04

Is Genolve safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.0.1)

As of 2026-11-04. 1 issue is on record for older versions; version 5.0.6 or newer fixes all of them that state a fix.

Latest version
6.0.1
Last updated
2026-09-06
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2.4+

Create professional business graphics, product images, social media, slide shows, flyers, brochures, infographics, podcasts with AI. — by Genolve

What to do

  1. Update to the latest version (6.0.1). Anything older than 5.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get genolve-toolkit --field=version shows what you run; wp plugin update genolve-toolkit updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-1359 · published 2026-07-11

Privilege escalation in Genolve (5.0.5 and older)

Affected
5.0.5 and older
Fixed in
5.0.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Wordfence
Details from the advisory

The Genolve – AI image AI video generation plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the genolve_setOpt() function in all versions up to, and including, 5.0.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to update arbitrary WordPress options, including enabling user registration and setting the default role to administrator, resulting in privilege escalation.

NVD CVE-2026-1359Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Genolve vulnerability status badge
<a href="https://laskyr.com/plugins/genolve-toolkit"><img src="https://laskyr.com/plugins/genolve-toolkit/badge.svg" alt="Genolve vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit