Plugins · generic-elements-for-elementor · data as of 2026-11-04
Is Generic Elements safe? Known vulnerabilities and latest version
- Latest version
- 1.3.0
- Last updated
- 2026-11-01
- Active installs
- 500+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.3+
Generic Elements is the most complete elementor design toolkit which enhanced the power of elementor plugin. — by Nasir Uddin
What to do
- Update to the latest version (1.3.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get generic-elements-for-elementor --field=version shows what you run; wp plugin update generic-elements-for-elementor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-62082 · published 2025-12-09
Stored cross-site scripting (XSS) in Generic Elements (1.2.9 and older)
- Affected
- 1.2.9 and older
- Fixed in
- 1.3.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nasir Uddin Generic Elements generic-elements-for-elementor allows Stored XSS.This issue affects Generic Elements: from n/a through <= 1.2.9.
medium 6.4 CVE-2025-9080 · published 2025-10-03
Stored cross-site scripting (XSS) in Generic Elements (1.2.8 and older)
- Affected
- 1.2.8 and older
- Fixed in
- 1.2.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Generic Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widget fields in version 1.2.8 and earlier. This is due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.5 CVE-2024-53709 · published 2024-12-02
Cross-site scripting (XSS) in Generic Elements (1.2.5 and older)
- Affected
- 1.2.5 and older
- Fixed in
- 1.2.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nasir Uddin Generic Elements generic-elements-for-elementor allows DOM-Based XSS.This issue affects Generic Elements: from n/a through <= 1.2.5.
Recent activity
- 2026-11-01 — latest release on wordpress.org (1.3.0).
- 2025-12-09 — Stored cross-site scripting (XSS) disclosed (CVE-2025-62082), fixed in 1.3.0.
- 2025-10-03 — Stored cross-site scripting (XSS) disclosed (CVE-2025-9080), fixed in 1.2.9.
- 2024-12-02 — Cross-site scripting (XSS) disclosed (CVE-2024-53709), fixed in 1.2.6.
Get an email when Generic Elements has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Generic Elements (generic-elements-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/generic-elements-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/generic-elements-for-elementor"><img src="https://laskyr.com/plugins/generic-elements-for-elementor/badge.svg" alt="Generic Elements vulnerability status"></a>