Skip to content
Laskyr

Plugins · generate-security-txt · data as of 2026-11-04

Is Generate Security.txt safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.14)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.13 or newer fixes all of them that state a fix.

Latest version
1.0.14
Last updated
2026-06-29
Active installs
300+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

With a security.txt file, ethical hackers can easily send you a notification when they have found a vulnerability on your website. — by Vereniging van Registrars

What to do

  1. Update to the latest version (1.0.14). Anything older than 1.0.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get generate-security-txt --field=version shows what you run; wp plugin update generate-security-txt updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-9616 · published 2026-06-24

Missing authorization check in Generate Security.txt (1.0.12 and older)

Affected
1.0.12 and older
Fixed in
1.0.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Generate Security.txt plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.0.12. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete the site's security.txt file from the server filesystem or create the .well-known directory by directly invoking the delete_securitytxt or create_wellknown_folder AJAX actions.

NVD CVE-2026-9616Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Generate Security.txt vulnerability status badge
<a href="https://laskyr.com/plugins/generate-security-txt"><img src="https://laskyr.com/plugins/generate-security-txt/badge.svg" alt="Generate Security.txt vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit