Skip to content
Laskyr

Plugins · gdpr-framework · data as of 2026-11-04

Is The GDPR Framework By Data443 safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.5.1 or newer fixes all of them that state a fix.

Latest version
2.5.1
Last updated
2026-10-17
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Easy to use tools to help make your website GDPR-compliant. Fully documented, extendable and developer-friendly. Extensions to enterprise GDPR compli … — by Data443 Risk Mitigation, Inc.

What to do

  1. Update to the latest version (2.5.1). Anything older than 2.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gdpr-framework --field=version shows what you run; wp plugin update gdpr-framework updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-39797 · published 2026-10-06

PHP object injection in The GDPR Framework By Data443 (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in GDPR Framework By Data443 <= 2.5.0 versions.

NVD CVE-2026-39797Patchstack advisory

medium 6.5 CVE-2026-14816 · published 2026-08-04

Missing authorization check in The GDPR Framework By Data443 (older than 2.4.0)

Affected
older than 2.4.0
Fixed in
2.4.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The GDPR Framework By Data443 WordPress plugin before 2.4.0 does not properly verify authorization or the identity of the data subject when recording cookie-consent choices and privacy requests, allowing unauthenticated attackers to forge consent records for arbitrary email addresses and to flood the site's privacy-request queue with arbitrary entries.

NVD CVE-2026-14816WPScan advisory

medium 4.8 CVE-2024-13621 · published 2025-05-15

Stored cross-site scripting (XSS) in The GDPR Framework By Data443 (older than 2.2.0)

Affected
older than 2.2.0
Fixed in
2.2.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The GDPR Framework By Data443 WordPress plugin before 2.2.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-13621WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
The GDPR Framework By Data443 vulnerability status badge
<a href="https://laskyr.com/plugins/gdpr-framework"><img src="https://laskyr.com/plugins/gdpr-framework/badge.svg" alt="The GDPR Framework By Data443 vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit