Skip to content
Laskyr

Plugins · gd-security-headers · data as of 2026-11-04

Is GD Security Headers safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9)

As of 2026-11-04. 3 issues are on record for older versions; version 1.9 or newer fixes all of them that state a fix.

Latest version
1.9
Last updated
2026-05-12
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Configure various security-related HTTP headers, including CSP, XSS, Referrer Policy and more. — by Milan Petrovic

What to do

  1. Update to the latest version (1.9). Anything older than 1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gd-security-headers --field=version shows what you run; wp plugin update gd-security-headers updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57403 · published 2026-07-13

Reflected cross-site scripting (XSS) in GD Security Headers (1.8 and older)

Affected
1.8 and older
Fixed in
1.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Milan Petrovic GD Security Headers gd-security-headers allows Reflected XSS.This issue affects GD Security Headers: from n/a through <= 1.8.

NVD CVE-2026-57403Patchstack advisory

high 7.2 CVE-2023-46821 · published 2023-11-06

SQL injection in GD Security Headers (1.7 and older)

Affected
1.7 and older
Fixed in
1.7.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Milan Petrovic GD Security Headers allows auth. (admin+) SQL Injection.This issue affects GD Security Headers: from n/a through 1.7.

NVD CVE-2023-46821Patchstack advisory

medium 6.1 CVE-2023-40330 · published 2023-09-27

Reflected cross-site scripting (XSS) in GD Security Headers (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Milan Petrovic GD Security Headers plugin <= 1.6.1 versions.

NVD CVE-2023-40330Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GD Security Headers vulnerability status badge
<a href="https://laskyr.com/plugins/gd-security-headers"><img src="https://laskyr.com/plugins/gd-security-headers/badge.svg" alt="GD Security Headers vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit