Skip to content
Laskyr

Plugins · gd-rating-system · data as of 2026-11-04

Is GD Rating System safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7.2)

As of 2026-11-04. 7 issues are on record for older versions; version 3.7.2 or newer fixes all of them that state a fix.

Latest version
3.7.2
Last updated
2026-10-01
Active installs
1,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.2 · PHP 7.4+

Powerful, highly customizable and versatile ratings plugin to allow your users to vote for anything you want. — by Milan Petrovic

What to do

  1. Update to the latest version (3.7.2). Anything older than 3.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gd-rating-system --field=version shows what you run; wp plugin update gd-rating-system updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-93430 · published 2026-10-03

Stored cross-site scripting (XSS) in GD Rating System (3.7.1 and older)

Affected
3.7.1 and older
Fixed in
3.7.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GD Rating System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'title' and 'url' Render Args in gdrts_live_handler AJAX in all versions up to, and including, 3.7.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Although the AJAX action requires a per-item nonce, that nonce is publicly emitted in the page's <script class="gdrts-rating-data"> JSON block on every page rendering the rating item, making it obtainable by any unauthenticated visitor and therefore not an authentication barrier.

NVD CVE-2026-93430Wordfence advisoryCode change (fix)Plugin source

high 8.5 CVE-2026-57771 · published 2026-07-13

SQL injection in GD Rating System (3.7 and older)

Affected
3.7 and older
Fixed in
3.7.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Milan Petrovic GD Rating System gd-rating-system allows Blind SQL Injection.This issue affects GD Rating System: from n/a through <= 3.7.

NVD CVE-2026-57771Patchstack advisory

critical 9.3 CVE-2026-42639 · published 2026-06-15

SQL injection in GD Rating System (3.6.2 and older)

Affected
3.6.2 and older
Fixed in
3.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in GD Rating System <= 3.6.2 versions.

NVD CVE-2026-42639Patchstack advisory

medium 6.4 CVE-2024-11198 · published 2024-11-19

Stored cross-site scripting (XSS) in GD Rating System (3.6.1 and older)

Affected
3.6.1 and older
Fixed in
3.6.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GD Rating System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘extra_class’ parameter in all versions up to, and including, 3.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11198Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.3 CVE-2024-38709 · published 2024-07-12

File inclusion in GD Rating System (3.6 and older)

Affected
3.6 and older
Fixed in
3.6.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Milan Petrovic GD Rating System allows PHP Local File Inclusion.This issue affects GD Rating System: from n/a through 3.6.

NVD CVE-2024-38709Patchstack advisory

medium 6.1 CVE-2024-25093 · published 2024-02-29

Stored cross-site scripting (XSS) in GD Rating System (3.5 and older)

Affected
3.5 and older
Fixed in
3.5.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Milan Petrovic GD Rating System allows Stored XSS.This issue affects GD Rating System: from n/a through 3.5.

NVD CVE-2024-25093Patchstack advisory

medium 6.1 CVE-2017-18591 · published 2019-08-27

Cross-site scripting (XSS) in GD Rating System (older than 2.1)

Affected
older than 2.1
Fixed in
2.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The gd-rating-system plugin before 2.1 for WordPress has XSS in log.php.

NVD CVE-2017-18591wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GD Rating System vulnerability status badge
<a href="https://laskyr.com/plugins/gd-rating-system"><img src="https://laskyr.com/plugins/gd-rating-system/badge.svg" alt="GD Rating System vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit