Skip to content
Laskyr

Plugins · garden-gnome-package · data as of 2026-11-04

Is Garden Gnome Package safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.4)

As of 2026-11-04. 4 issues are on record for older versions; version 2.5.0 or newer fixes all of them that state a fix.

Latest version
2.5.4
Last updated
2026-10-15
Active installs
4,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Display panoramas, virtual tours or object movies created with Pano2VR and Object2VR. — by Chief Gnome

What to do

  1. Update to the latest version (2.5.4). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get garden-gnome-package --field=version shows what you run; wp plugin update garden-gnome-package updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-39683 · published 2026-04-08

Cross-site scripting (XSS) in Garden Gnome Package (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.5.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Chief Gnome Garden Gnome Package garden-gnome-package allows DOM-Based XSS.This issue affects Garden Gnome Package: from n/a through <= 2.4.1.

NVD CVE-2026-39683Patchstack advisory

high 8.8 CVE-2024-12854 · published 2025-01-08

Arbitrary file upload in Garden Gnome Package (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.4.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Garden Gnome Package plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the functionality that automatically extracts 'ggpkg' files that have been uploaded in all versions up to, and including, 2.3.0. This makes it possible for authenticated attackers, with Author-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2024-12854Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-8657 · published 2024-09-24

Stored cross-site scripting (XSS) in Garden Gnome Package (2.2.9 and older)

Affected
2.2.9 and older
Fixed in
2.3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Garden Gnome Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's ggpkg shortcode in all versions up to, and including, 2.2.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8657Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-5664 · published 2023-11-22

Stored cross-site scripting (XSS) in Garden Gnome Package (2.2.8 and older)

Affected
2.2.8 and older
Fixed in
2.2.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Garden Gnome Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ggpkg' shortcode in all versions up to, and including, 2.2.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 2.2.7 and fully patched in version 2.2.9.

NVD CVE-2023-5664Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Garden Gnome Package vulnerability status badge
<a href="https://laskyr.com/plugins/garden-gnome-package"><img src="https://laskyr.com/plugins/garden-gnome-package/badge.svg" alt="Garden Gnome Package vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit