Plugins · gantry5 · data as of 2026-11-04
Is Gantry 5 Framework safe? Known vulnerabilities and latest version
- Latest version
- 5.6.5
- Last updated
- 2026-10-19
- Active installs
- 7,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1.0+
Gantry is a comprehensive set of building blocks to enable the rapid development and realization of a design into a flexible and powerful web platform — by Gantry
What to do
- Update to the latest version (5.6.5). Anything older than 5.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gantry5 --field=version shows what you run; wp plugin update gantry5 updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-110889 · published 2026-10-17
Information disclosure in Gantry 5 Framework (5.6.4 and older)
- Affected
- 5.6.4 and older
- Fixed in
- 5.6.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Generation of Error Message Containing Sensitive Information vulnerability in Gantry Gantry 5 Framework gantry5 allows Retrieve Embedded Sensitive Data.This issue affects Gantry 5 Framework: from n/a through 5.6.4.
Recent activity
- 2026-10-19 — latest release on wordpress.org (5.6.5).
- 2026-10-17 — Information disclosure disclosed (CVE-2026-110889), fixed in 5.6.5.
Get an email when Gantry 5 Framework has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gantry 5 Framework (gantry5) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gantry5 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gantry5"><img src="https://laskyr.com/plugins/gantry5/badge.svg" alt="Gantry 5 Framework vulnerability status"></a>