Plugins · gallery-plugin · data as of 2026-11-04
Is Gallery by BestWebSoft safe? Known vulnerabilities and latest version
- Latest version
- 4.8.2
- Last updated
- 2026-10-31
- Active installs
- 10,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Add beautiful, fully responsive galleries, albums, images, and categories to your WordPress website quickly and easily. Showcase your portfolio, photo … — by bestwebsoft
What to do
- Update to the latest version (4.8.2). Anything older than 4.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get gallery-plugin --field=version shows what you run; wp plugin update gallery-plugin updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-2497 · published 2026-08-16
SQL injection in Gallery by BestWebSoft (4.7.9 and older)
- Affected
- 4.7.9 and older
- Fixed in
- 4.8.0 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Gallery by BestWebSoft plugin for WordPress is vulnerable to SQL Injection via the '_gallery_order_{post_id}' parameter array keys in all versions up to, and including, 4.7.9. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. The `gllr_save_postdata()` function stores unsanitized array keys from `$_POST` directly into post meta, which are later used in SQL queries without prepared statements. This makes it possible for authenticated attackers, with Editor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-2497Wordfence advisoryCode change (fix)Plugin source
high 8.5 CVE-2026-57642 · published 2026-06-26
SQL injection in Gallery by BestWebSoft (4.7.8 and older)
- Affected
- 4.7.8 and older
- Fixed in
- 4.7.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor SQL Injection in Gallery <= 4.7.8 versions.
high 7.2 CVE-2024-13906 · published 2025-03-07
PHP object injection in Gallery by BestWebSoft (4.7.3 and older)
- Affected
- 4.7.3 and older
- Fixed in
- 4.7.4 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Gallery by BestWebSoft – Customizable Image and Photo Galleries for WordPress plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 4.7.3 via deserialization of untrusted input in the 'import_gallery_from_csv' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.
NVD CVE-2024-13906Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2023-0764 · published 2023-04-17
Security issue in Gallery by BestWebSoft (older than 4.7.0)
- Affected
- older than 4.7.0
- Fixed in
- 4.7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Gallery by BestWebSoft WordPress plugin before 4.7.0 does not perform proper sanitization of gallery information, leading to a Stored Cross-Site Scription vulnerability. The attacker must have at least the privileges of the Author role.
high 8.8 CVE-2023-0765 · published 2023-04-17
SQL injection in Gallery by BestWebSoft (older than 4.7.0)
- Affected
- older than 4.7.0
- Fixed in
- 4.7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Gallery by BestWebSoft WordPress plugin before 4.7.0 does not properly escape values used in SQL queries, leading to an Blind SQL Injection vulnerability. The attacker must have at least the privileges of an Author, and the vendor's Slider plugin (https://wordpress.org/plugins/slider-bws/) must also be installed for this vulnerability to be exploitable.
Recent activity
- 2026-10-31 — latest release on wordpress.org (4.8.2).
- 2026-08-16 — SQL injection disclosed (CVE-2026-2497), fixed in 4.8.0.
- 2026-06-26 — SQL injection disclosed (CVE-2026-57642), fixed in 4.7.9.
- 2025-03-07 — PHP object injection disclosed (CVE-2024-13906), fixed in 4.7.4.
Get an email when Gallery by BestWebSoft has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Gallery by BestWebSoft (gallery-plugin) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bestwebsoft (5 tracked)
Types found in this plugin: SQL injection (3) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/gallery-plugin (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/gallery-plugin"><img src="https://laskyr.com/plugins/gallery-plugin/badge.svg" alt="Gallery by BestWebSoft vulnerability status"></a>