Skip to content
Laskyr

Plugins · gallery-custom-links · data as of 2026-11-04

Is Gallery Custom Links safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.6)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.4 or newer fixes all of them that state a fix.

Latest version
2.3.6
Last updated
2026-10-30
Active installs
30,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Gallery Custom Links allows you to link images to a specified URL. Tested with WordPress Gallery, Gutenberg, the Meow Gallery and others. — by Jordy Meow

What to do

  1. Update to the latest version (2.3.6). Anything older than 2.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gallery-custom-links --field=version shows what you run; wp plugin update gallery-custom-links updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-107757 · published 2026-10-14

Stored cross-site scripting (XSS) in Gallery Custom Links (2.3.3 and older)

Affected
2.3.3 and older
Fixed in
2.3.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gallery Custom Links plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name (profile.php) + comment (wp-comments-post.php)' parameter in all versions up to, and including, 2.3.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit requires two coordinated inputs from the same authenticated attacker: an HTML comment payload stored in a comment body (preserved verbatim by WordPress comment kses) and a matching simple_html_dom noise key placed in the attacker's display_name (which survives esc_attr() intact), with substitution occurring after both filters have run during the plugin's default-on output-buffering pass over the full rendered page.

NVD CVE-2026-107757Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2025-60104 · published 2025-09-26

Stored cross-site scripting (XSS) in Gallery Custom Links (2.2.5 and older)

Affected
2.2.5 and older
Fixed in
2.2.6
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Jordy Meow Gallery Custom Links gallery-custom-links allows Stored XSS.This issue affects Gallery Custom Links: from n/a through <= 2.2.5.

NVD CVE-2025-60104Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gallery Custom Links vulnerability status badge
<a href="https://laskyr.com/plugins/gallery-custom-links"><img src="https://laskyr.com/plugins/gallery-custom-links/badge.svg" alt="Gallery Custom Links vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit