Skip to content
Laskyr

Plugins · gallery-by-supsystic · data as of 2026-11-04

Is Photo Gallery by Supsystic safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.21.7)

As of 2026-11-04. 5 issues are on record for older versions; version 1.21.1 or newer fixes all of them that state a fix.

Latest version
1.21.7
Last updated
2026-10-30
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Responsive photo and image galleries with masonry, albums and a lightbox. Bulk upload, drag-and-drop ordering, Gutenberg block and Elementor widget. — by supsystic

What to do

  1. Update to the latest version (1.21.7). Anything older than 1.21.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get gallery-by-supsystic --field=version shows what you run; wp plugin update gallery-by-supsystic updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-102399 · published 2026-09-30

Cross-site request forgery (CSRF) in Photo Gallery by Supsystic (1.21.0 and older)

Affected
1.21.0 and older
Fixed in
1.21.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Photo Gallery by Supsystic <= 1.21.0 versions.

NVD CVE-2026-102399Patchstack advisory

medium 5.9 CVE-2026-24628 · published 2026-07-23

Cross-site scripting (XSS) in Photo Gallery by Supsystic (1.16.3 and older)

Affected
1.16.3 and older
Fixed in
1.17.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Administrator Cross Site Scripting (XSS) in Photo Gallery by Supsystic <= 1.16.3 versions.

NVD CVE-2026-24628Patchstack advisory

medium 4.8 CVE-2024-29921 · published 2024-03-27

Cross-site scripting (XSS) in Photo Gallery by Supsystic (1.15.16 and older)

Affected
1.15.16 and older
Fixed in
1.15.17
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in supsystic Photo Gallery by Supsystic gallery-by-supsystic.This issue affects Photo Gallery by Supsystic: from n/a through <= 1.15.16.

NVD CVE-2024-29921Patchstack advisoryPatchstack advisory

medium 4.3 CVE-2021-36891 · published 2022-06-15

Cross-site request forgery (CSRF) in Photo Gallery by Supsystic (1.15.5 and older)

Affected
1.15.5 and older
Fixed in
1.15.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Photo Gallery by Supsystic plugin <= 1.15.5 at WordPress allows changing the plugin settings.

NVD CVE-2021-36891Patchstack advisorywordpress.org

high 8.8 CVE-2016-10918 · published 2019-08-22

Cross-site request forgery (CSRF) in Photo Gallery by Supsystic (older than 1.8.6)

Affected
older than 1.8.6
Fixed in
1.8.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The gallery-by-supsystic plugin before 1.8.6 for WordPress has CSRF.

NVD CVE-2016-10918wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Photo Gallery by Supsystic vulnerability status badge
<a href="https://laskyr.com/plugins/gallery-by-supsystic"><img src="https://laskyr.com/plugins/gallery-by-supsystic/badge.svg" alt="Photo Gallery by Supsystic vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit