Skip to content
Laskyr

Plugins · g-ffl-cockpit · data as of 2026-11-04

Is g-FFL Cockpit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.39)

As of 2026-11-04. 2 issues are on record for older versions; version 1.8.0 or newer fixes all of them that state a fix.

Latest version
2.0.39
Last updated
2026-10-23
Active installs
500+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Built by a FFL, for FFL's. Automate inventory synchronization and order fulfillment with multiple distributors. — by garidium

What to do

  1. Update to the latest version (2.0.39). Anything older than 1.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get g-ffl-cockpit --field=version shows what you run; wp plugin update g-ffl-cockpit updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-12720 · published 2025-12-06

Missing authorization check in g-FFL Cockpit (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.8.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The g-FFL Cockpit plugin for WordPress is vulnerable to unauthorized modification of data due to IP-based authorization that can be spoofed in the handle_enqueue_only() function in all versions up to, and including, 1.7.1. This makes it possible for unauthenticated attackers to delete arbitrary products.

NVD CVE-2025-12720Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

medium 5.3 CVE-2025-12721 · published 2025-12-06

Information disclosure in g-FFL Cockpit (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.8.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The g-FFL Cockpit plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.7.1 via the /server_status REST API endpoint due to a lack of capability checks. This makes it possible for unauthenticated attackers to extract information about the server.

NVD CVE-2025-12721Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
g-FFL Cockpit vulnerability status badge
<a href="https://laskyr.com/plugins/g-ffl-cockpit"><img src="https://laskyr.com/plugins/g-ffl-cockpit/badge.svg" alt="g-FFL Cockpit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit