Plugins · fx-currency-converter · data as of 2026-11-04
Is FX Currency Converter safe? Known vulnerabilities and latest version
- Latest version
- 0.3.2
- Last updated
- 2026-08-20
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Easy-to-use, free currency converter. 🔑 No API key needed. ❤️ Install and enjoy. — by falselight
What to do
- Update to the latest version (0.3.2). Anything older than 0.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get fx-currency-converter --field=version shows what you run; wp plugin update fx-currency-converter updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-13963 · published 2025-12-12
Stored cross-site scripting (XSS) in FX Currency Converter (0.2.0 and older)
- Affected
- 0.2.0 and older
- Fixed in
- 0.2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The FX Currency Converter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'fxcc_convert' shortcode in all versions up to, and including, 0.2.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-13963Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-20 — latest release on wordpress.org (0.3.2).
- 2025-12-12 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13963), fixed in 0.2.1.
Get an email when FX Currency Converter has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for FX Currency Converter (fx-currency-converter) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/fx-currency-converter (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/fx-currency-converter"><img src="https://laskyr.com/plugins/fx-currency-converter/badge.svg" alt="FX Currency Converter vulnerability status"></a>