Skip to content
Laskyr

Plugins · fullscreen-galleria · data as of 2026-11-04

Is Fullscreen Galleria safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.13)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.13 or newer fixes all of them that state a fix.

Latest version
1.6.13
Last updated
2026-08-05
Active installs
800+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

A simple fullscreen gallery to Wordpress — by pdamsten

What to do

  1. Update to the latest version (1.6.13). Anything older than 1.6.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fullscreen-galleria --field=version shows what you run; wp plugin update fullscreen-galleria updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-16079 · published 2026-08-16

SQL injection in Fullscreen Galleria (1.6.12 and older)

Affected
1.6.12 and older
Fixed in
1.6.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Fullscreen Galleria plugin for WordPress is vulnerable to generic SQL Injection via 'href' Attribute in Post Content in all versions up to, and including, 1.6.12 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-16079Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-29801 · published 2024-03-27

Stored cross-site scripting (XSS) in Fullscreen Galleria (1.6.11 and older)

Affected
1.6.11 and older
Fixed in
1.6.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Petri Damstén Fullscreen Galleria allows Stored XSS.This issue affects Fullscreen Galleria: from n/a through 1.6.11.

NVD CVE-2024-29801Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fullscreen Galleria vulnerability status badge
<a href="https://laskyr.com/plugins/fullscreen-galleria"><img src="https://laskyr.com/plugins/fullscreen-galleria/badge.svg" alt="Fullscreen Galleria vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit