Skip to content
Laskyr

Plugins · ft-rockpress · data as of 2026-11-04

Is RockPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.18)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.18 or newer fixes all of them that state a fix.

Latest version
1.0.18
Last updated
2026-03-07
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.0+

Introducing the easiest way to display information from Rock RMS on your church WordPress site. — by FireTree Design

What to do

  1. Update to the latest version (1.0.18). Anything older than 1.0.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ft-rockpress --field=version shows what you run; wp plugin update ft-rockpress updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-3550 · published 2026-03-20

Missing authorization check in RockPress (1.0.17 and older)

Affected
1.0.17 and older
Fixed in
1.0.18 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The RockPress plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.0.17. This is due to missing capability checks on multiple AJAX actions (rockpress_import, rockpress_import_status, rockpress_last_import, rockpress_reset_import, and rockpress_check_services) combined with the plugin's nonce being exposed to all authenticated users via an unconditionally enqueued admin script. The plugin enqueues the 'rockpress-admin' script on all admin pages (including profile.php) without any page or capability restrictions, and the nonce for the 'rockpress-nonce' action is passed to this script via wp_localize_script. Since the AJAX handlers only verify this nonce and do not check current_user_can(), any authenticated user, including Subscribers, can extract the nonce from any admin page's HTML source and use it to trigger imports, reset import data (deleting options), check service connectivity, and read import status information. This makes it possible for authenticated attackers, with Subscriber-level access and above, to trigger resource-intensive import operations, reset import tracking data, and perform system connection checks that should be restricted to administrators.

NVD CVE-2026-3550Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
RockPress vulnerability status badge
<a href="https://laskyr.com/plugins/ft-rockpress"><img src="https://laskyr.com/plugins/ft-rockpress/badge.svg" alt="RockPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit