Plugins · frontis-blocks · data as of 2026-11-04
Is Frontis Blocks safe? Known vulnerabilities and latest version
- Status
- Closed 2026-06-08
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate frontis-blocks && wp plugin delete frontis-blocks
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
high 7.2 CVE-2026-0807 · published 2026-01-24
Server-side request forgery (SSRF) in Frontis Blocks (1.1.6 and older)
- Affected
- 1.1.6 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Frontis Blocks plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.1.6. This is due to insufficient restriction on the 'url' parameter in the 'template_proxy' function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application via the '/template-proxy/' and '/proxy-image/' endpoint.
NVD CVE-2026-0807Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2025-68030 · published 2026-01-22
Server-side request forgery (SSRF) in Frontis Blocks (1.1.5 and older)
- Affected
- 1.1.5 and older
- Fixed in
- 1.1.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in WP Messiah Frontis Blocks frontis-blocks allows Server Side Request Forgery.This issue affects Frontis Blocks: from n/a through <= 1.1.5.
Recent activity
- 2026-06-08 — closed on wordpress.org (Guideline Violation).
- 2026-01-24 — Server-side request forgery (SSRF) disclosed (CVE-2026-0807), fix version not stated.
- 2026-01-22 — Server-side request forgery (SSRF) disclosed (CVE-2025-68030), fixed in 1.1.6.
Get an email when Frontis Blocks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Frontis Blocks (frontis-blocks) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Server-side request forgery (SSRF) (2)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/frontis-blocks (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/frontis-blocks"><img src="https://laskyr.com/plugins/frontis-blocks/badge.svg" alt="Frontis Blocks vulnerability status"></a>