Plugins · frontend-user-notes · data as of 2026-11-04
Is Frontend User Notes safe? Known vulnerabilities and latest version
- Latest version
- 2.3.1
- Last updated
- 2026-11-03
- Active installs
- 70+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Allow site members to add and save personal notes from frontend. Suited for membership and e-learning sites. Fast, secure and fully ajax loading. — by Abu Bakar
What to do
- Update to the latest version (2.3.1). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get frontend-user-notes --field=version shows what you run; wp plugin update frontend-user-notes updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-7047 · published 2026-06-06
Cross-site request forgery (CSRF) in Frontend User Notes (2.1.1 and older)
- Affected
- 2.1.1 and older
- Fixed in
- 2.2.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Frontend User Notes plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.1.1. This is due to missing or incorrect nonce validation on the funp_ajax_modify_notes function. This makes it possible for unauthenticated attackers to trick a logged-in user into visiting a malicious page, causing unauthorized overwriting of that victim's own note content via a forged cross-site request to wp_update_post() via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Due to ownership enforcement comparing the note's stored _funp_single_user_id meta against the current session's user ID, the attack is limited to modifying only notes belonging to the tricked victim, and cannot be used to alter notes owned by arbitrary third-party users.
NVD CVE-2026-7047Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-12071 · published 2026-02-18
Missing authorization check in Frontend User Notes (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Frontend User Notes plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.1.0 via the 'funp_ajax_modify_notes' AJAX endpoint due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify arbitrary notes that do not belong to them.
Recent activity
- 2026-11-03 — latest release on wordpress.org (2.3.1).
- 2026-06-06 — Cross-site request forgery (CSRF) disclosed (CVE-2026-7047), fixed in 2.2.0.
- 2026-02-18 — Missing authorization check disclosed (CVE-2025-12071), fixed in 2.1.1.
Get an email when Frontend User Notes has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Frontend User Notes (frontend-user-notes) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/frontend-user-notes (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/frontend-user-notes"><img src="https://laskyr.com/plugins/frontend-user-notes/badge.svg" alt="Frontend User Notes vulnerability status"></a>