Skip to content
Laskyr

Plugins · frontend-post-submission-manager-lite · data as of 2026-11-04

Is Frontend Post Submission Manager Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.5)

As of 2026-11-04. 5 issues are on record for older versions; version 1.3.5 or newer fixes all of them that state a fix.

Latest version
1.3.5
Last updated
2026-09-26
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Create guest and logged-in frontend post forms with seeded setup, simple fields, five templates, notifications, and captcha protection. — by WP Shuffle

What to do

  1. Update to the latest version (1.3.5). Anything older than 1.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get frontend-post-submission-manager-lite --field=version shows what you run; wp plugin update frontend-post-submission-manager-lite updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-96649 · published 2026-09-30

DOM-based cross-site scripting (XSS) in Frontend Post Submission Manager Lite (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via post_content Parameter (data-label DOM Sink) in all versions up to, and including, 1.3.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the site operator to have enabled guest post submission via the [fpsm] shortcode, which registers a publicly accessible AJAX handler gated only by a nonce emitted on every page containing the shortcode.

NVD CVE-2026-96649Wordfence advisoryPlugin source

medium 6.1 CVE-2026-1296 · published 2026-02-18

Open redirect in Frontend Post Submission Manager Lite (1.0.0 to 1.2.7)

Affected
1.0.0 to 1.2.7
Fixed in
1.2.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Frontend Post Submission Manager Lite plugin for WordPress is vulnerable to Open Redirection in all versions up to, and including, 1.2.7 due to insufficient validation on the 'requested_page' POST parameter in the verify_username_password function. This makes it possible for unauthenticated attackers to redirect users to potentially malicious sites if they can successfully trick them into performing an action such as clicking on a link.

NVD CVE-2026-1296Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-14913 · published 2025-12-26

Missing authorization check in Frontend Post Submission Manager Lite (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin plugin for WordPress is vulnerable to unauthorized loss of data due to an incorrect authorization check on the 'media_delete_action' function in all versions up to, and including, 1.2.6. This makes it possible for unauthenticated attackers to delete arbitrary attachments.

NVD CVE-2025-14913Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-14080 · published 2025-12-21

Missing authorization check in Frontend Post Submission Manager Lite (1.2.5 and older)

Affected
1.2.5 and older
Fixed in
1.2.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Frontend Post Submission Manager Lite plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.2.5. This is due to missing authorization checks on the post update functionality in the fpsml_form_process AJAX action. This makes it possible for unauthenticated attackers to modify arbitrary posts by providing a post_id parameter via the guest posting form, allowing them to change post titles, content, excerpts, and remove post authors.

NVD CVE-2025-14080Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-8427 · published 2024-09-06

Missing authorization check in Frontend Post Submission Manager Lite (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Frontend Post Submission Manager Lite – Frontend Posting WordPress Plugin plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_global_settings and process_form_edit functions in all versions up to, and including, 1.2.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's settings and forms.

NVD CVE-2024-8427Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Frontend Post Submission Manager Lite vulnerability status badge
<a href="https://laskyr.com/plugins/frontend-post-submission-manager-lite"><img src="https://laskyr.com/plugins/frontend-post-submission-manager-lite/badge.svg" alt="Frontend Post Submission Manager Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit