Skip to content
Laskyr

Plugins · front-end-pm · data as of 2026-11-04

Is Front End PM safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (11.4.7)

As of 2026-11-04. 2 issues are on record for older versions; version 11.4.7 or newer fixes all of them that state a fix.

Latest version
11.4.7
Last updated
2026-10-12
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Front End PM is a Private Messaging system and a secure contact form to your WordPress site.This is full functioning messaging system from front end. — by Shamim Hasan

What to do

  1. Update to the latest version (11.4.7). Anything older than 11.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get front-end-pm --field=version shows what you run; wp plugin update front-end-pm updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-39788 · published 2026-10-06

Cross-site scripting (XSS) in Front End PM (11.4.6 and older)

Affected
11.4.6 and older
Fixed in
11.4.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Cross Site Scripting (XSS) in Front End PM <= 11.4.6 versions.

NVD CVE-2026-39788Patchstack advisory

medium 6.5 CVE-2023-4930 · published 2023-11-06

Security issue in Front End PM (older than 11.4.3)

Affected
older than 11.4.3
Fixed in
11.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Front End PM WordPress plugin before 11.4.3 does not block listing the contents of the directories where it stores attachments to private messages, allowing unauthenticated visitors to list and download private attachments if the autoindex feature of the web server is enabled.

NVD CVE-2023-4930WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Front End PM vulnerability status badge
<a href="https://laskyr.com/plugins/front-end-pm"><img src="https://laskyr.com/plugins/front-end-pm/badge.svg" alt="Front End PM vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit