Skip to content
Laskyr

Plugins · foxtool · data as of 2026-11-04

Is Foxtool All-in-One safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.5.4 or newer fixes all of them that state a fix.

Latest version
2.5.4
Last updated
2026-08-22
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Summarize the essential functions for managing a WordPress website — by Fox Theme

What to do

  1. Update to the latest version (2.5.4). Anything older than 2.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get foxtool --field=version shows what you run; wp plugin update foxtool updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-18317 · published 2026-09-18

Stored cross-site scripting (XSS) in Foxtool All-in-One (2.5.3 and older)

Affected
2.5.3 and older
Fixed in
2.5.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Foxtool All-in-One: Contact chat button, Custom login, Media optimize images plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.5.3. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify arbitrary subkeys of the foxtool_settings option, including enabling site-wide SVG uploads by toggling the media-up3 key, which can facilitate stored cross-site scripting via malicious SVG files.

NVD CVE-2026-18317Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-13408 · published 2025-12-12

Cross-site request forgery (CSRF) in Foxtool All-in-One (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Foxtool All-in-One: Contact chat button, Custom login, Media optimize images plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.5.2. This is due to missing or incorrect nonce validation on the foxtool_login_google() function. This makes it possible for unauthenticated attackers to establish an OAuth Connection via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-13408Wordfence advisoryCode change (fix)wordpress.orgplugins.svn.wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Foxtool All-in-One vulnerability status badge
<a href="https://laskyr.com/plugins/foxtool"><img src="https://laskyr.com/plugins/foxtool/badge.svg" alt="Foxtool All-in-One vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit