Skip to content
Laskyr

Plugins · fox-lms · data as of 2026-11-04

Is Fox LMS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.0.2)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.6.4 or newer fixes all of them that state a fix.

Latest version
1.1.0.2
Last updated
2026-10-23
Active installs
60+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Easily create online courses, lessons, and quizzes for your WordPress LMS website with this simple eLearning plugin for WordPress. — by Ays Pro

What to do

  1. Update to the latest version (1.1.0.2). Anything older than 1.0.6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fox-lms --field=version shows what you run; wp plugin update fox-lms updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-31922 · published 2026-03-13

SQL injection in Fox LMS (1.0.6.3 and older)

Affected
1.0.6.3 and older
Fixed in
1.0.6.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Ays Pro Fox LMS fox-lms allows Blind SQL Injection.This issue affects Fox LMS: from n/a through <= 1.0.6.3.

NVD CVE-2026-31922Patchstack advisory

critical 9.8 CVE-2025-14156 · published 2025-12-15

Privilege escalation in Fox LMS (1.0.4.7 to 1.0.5.1)

Affected
1.0.4.7 to 1.0.5.1
Fixed in
1.0.5.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Fox LMS – WordPress LMS Plugin plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.0.5.1. This is due to the plugin not properly validating the 'role' parameter when creating new users via the `/fox-lms/v1/payments/create-order` REST API endpoint. This makes it possible for unauthenticated attackers to create new user accounts with arbitrary roles, including administrator, leading to complete site compromise.

NVD CVE-2025-14156Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fox LMS vulnerability status badge
<a href="https://laskyr.com/plugins/fox-lms"><img src="https://laskyr.com/plugins/fox-lms/badge.svg" alt="Fox LMS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit