Plugins · forumwp · data as of 2026-11-04
Is ForumWP safe? Known vulnerabilities and latest version
- Latest version
- 2.1.9
- Last updated
- 2026-04-01
- Active installs
- 800+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.0+
Add a forum to your website with ForumWP. — by Ultimate Member
What to do
- Update to the latest version (2.1.9). Anything older than 2.1.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get forumwp --field=version shows what you run; wp plugin update forumwp updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2025-13746 · published 2026-01-06
Stored cross-site scripting (XSS) in ForumWP (2.1.6 and older)
- Affected
- 2.1.6 and older
- Fixed in
- 2.1.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ForumWP – Forum & Discussion Board plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the User's Display Name in all versions up to, and including, 2.1.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 4.3 CVE-2025-67474 · published 2025-12-09
Missing authorization check in ForumWP (2.1.4 and older)
- Affected
- 2.1.4 and older
- Fixed in
- 2.1.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ultimate Member ForumWP forumwp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ForumWP: from n/a through <= 2.1.4.
critical 9.8 CVE-2024-54367 · published 2024-12-16
PHP object injection in ForumWP (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in Ultimate Member ForumWP forumwp allows Object Injection.This issue affects ForumWP: from n/a through <= 2.1.0.
medium 6.1 CVE-2024-10879 · published 2024-12-06
Reflected cross-site scripting (XSS) in ForumWP (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ForumWP – Forum & Discussion Board plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.1.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-10879Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-11204 · published 2024-12-06
Reflected cross-site scripting (XSS) in ForumWP (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ForumWP – Forum & Discussion Board plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘url’ parameter in all versions up to, and including, 2.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-11204Wordfence advisoryCode change (fix)wordpress.orgPlugin source
high 8.8 CVE-2024-8428 · published 2024-09-06
Privilege escalation in ForumWP (2.0.2 and older)
- Affected
- 2.0.2 and older
- Fixed in
- 2.1.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ForumWP – Forum & Discussion Board Plugin plugin for WordPress is vulnerable to Privilege Escalation via Insecure Direct Object Reference in all versions up to, and including, 2.0.2 via the submit_form_handler due to missing validation on the 'user_id' user controlled key. This makes it possible for authenticated attackers, with subscriber-level access and above, to change the email address of administrative user accounts which can then be leveraged to reset the administrative users password and gain access to their account.
NVD CVE-2024-8428Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-04-01 — latest release on wordpress.org (2.1.9).
- 2026-01-06 — Stored cross-site scripting (XSS) disclosed (CVE-2025-13746), fixed in 2.1.7.
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-67474), fixed in 2.1.5.
- 2024-12-16 — PHP object injection disclosed (CVE-2024-54367), fixed in 2.1.1.
Get an email when ForumWP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ForumWP (forumwp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ultimate Member (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1) · PHP object injection (1) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/forumwp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/forumwp"><img src="https://laskyr.com/plugins/forumwp/badge.svg" alt="ForumWP vulnerability status"></a>