Skip to content
Laskyr

Plugins · fortis-for-woocommerce · data as of 2026-11-04

Is Fortis for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.4)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.1 or newer fixes all of them that state a fix.

Latest version
1.3.4
Last updated
2026-10-06
Active installs
300+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

This is the official Fortis extension to receive payments for WooCommerce. — by Fortis

What to do

  1. Update to the latest version (1.3.4). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get fortis-for-woocommerce --field=version shows what you run; wp plugin update fortis-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-15609 · published 2026-05-19

Security issue in Fortis for WooCommerce (older than 1.3.1)

Affected
older than 1.3.1
Fixed in
1.3.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Fortis for WooCommerce WordPress plugin before 1.3.1 may leak sensitive API keys to unauthenticated attackers, allowing them to query Fortis' API and retrieve sensitive customer information, like past orders, PII, etc.

NVD CVE-2025-15609WPScan advisory

medium 5.3 CVE-2026-0679 · published 2026-02-04

Missing authorization check in Fortis for WooCommerce (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.3.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Fortis for WooCommerce plugin for WordPress is vulnerable to authorization bypass due to an inverted nonce check in the 'check_fortis_notify_response' function in all versions up to, and including, 1.2.0. This makes it possible for unauthenticated attackers to update arbitrary WooCommerce order statuses to paid/processing/completed, effectively allowing them to mark orders as paid without payment.

NVD CVE-2026-0679Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Fortis for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/fortis-for-woocommerce"><img src="https://laskyr.com/plugins/fortis-for-woocommerce/badge.svg" alt="Fortis for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit