Plugins · forms-for-campaign-monitor · data as of 2026-11-04
Is Campaign Monitor for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 2.9.2
- Last updated
- 2026-05-05
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.3+
Make it easy for customers to subscribe to your Campaign Monitor mailing lists using any of the 5 elegant sign-up forms. — by Campaign Monitor
What to do
- Update to the latest version (2.9.2). Anything older than 2.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get forms-for-campaign-monitor --field=version shows what you run; wp plugin update forms-for-campaign-monitor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-0674 · published 2026-01-08
Missing authorization check in Campaign Monitor for WordPress (2.9.1 and older)
- Affected
- 2.9.1 and older
- Fixed in
- 2.9.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Campaign Monitor Campaign Monitor for WordPress allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Campaign Monitor for WordPress: from n/a through 2.9.1.
medium 5.3 CVE-2024-6569 · published 2024-07-27
Information disclosure in Campaign Monitor for WordPress (2.8.15 and older)
- Affected
- 2.8.15 and older
- Fixed in
- 2.8.16 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Campaign Monitor for WordPress plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.8.15. This is due the plugin not properly restricting direct access to /forms/views/admin/create.php and display_errors being enabled. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.
NVD CVE-2024-6569Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2023-38474 · published 2023-11-30
Reflected cross-site scripting (XSS) in Campaign Monitor for WordPress (2.8.12 and older)
- Affected
- 2.8.12 and older
- Fixed in
- 2.8.14 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Campaign Monitor Campaign Monitor for WordPress allows Reflected XSS.This issue affects Campaign Monitor for WordPress: from n/a through 2.8.12.
Recent activity
- 2026-05-05 — latest release on wordpress.org (2.9.2).
- 2026-01-08 — Missing authorization check disclosed (CVE-2026-0674), fixed in 2.9.2.
- 2024-07-27 — Information disclosure disclosed (CVE-2024-6569), fixed in 2.8.16.
- 2023-11-30 — Reflected cross-site scripting (XSS) disclosed (CVE-2023-38474), fixed in 2.8.14.
Get an email when Campaign Monitor for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Campaign Monitor for WordPress (forms-for-campaign-monitor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Sensitive data exposure (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/forms-for-campaign-monitor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/forms-for-campaign-monitor"><img src="https://laskyr.com/plugins/forms-for-campaign-monitor/badge.svg" alt="Campaign Monitor for WordPress vulnerability status"></a>