Skip to content
Laskyr

Plugins · formgent · data as of 2026-11-04

Is FormGent safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.12.4)

As of 2026-11-04. 5 issues are on record for older versions; version 1.12.3 or newer fixes all of them that state a fix.

Latest version
1.12.4
Last updated
2026-10-18
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

AI-powered form builder that’s built for performance, simplicity, and feels like a part of WordPress, not a separate platform. — by wpWax

What to do

  1. Update to the latest version (1.12.4). Anything older than 1.12.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get formgent --field=version shows what you run; wp plugin update formgent updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-94499 · published 2026-09-30

Missing authorization check in FormGent (1.12.2 and older)

Affected
1.12.2 and older
Fixed in
1.12.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in FormGent <= 1.12.2 versions.

NVD CVE-2026-94499Patchstack advisory

high 7.2 CVE-2025-15028 · published 2026-08-06

Stored cross-site scripting (XSS) in FormGent (1.9.2 and older)

Affected
1.9.2 and older
Fixed in
1.10.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FormGent – Next-Gen AI Form Builder for WordPress with Multi-Step, Quizzes, Payments & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via form submission fields in all versions up to, and including, 1.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-15028Wordfence advisoryCode change (fix)

critical 9.1 CVE-2026-3141 · published 2026-08-01

Arbitrary file deletion in FormGent (1.9.2 and older)

Affected
1.9.2 and older
Fixed in
1.10.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FormGent plugin for WordPress is vulnerable to unauthorized arbitrary file deletion due to a missing capability check on the /wp-json/formgent/responses/attachments REST API endpoint in all versions up to, and including, 1.9.2 This is due to the REST API route being registered without any authentication middleware in routes/rest/api.php. This makes it possible for unauthenticated attackers to delete arbitrary files within the formgent uploads directory. Additionally, on Linux servers where the wp-content/uploads/formgent directory does not yet exist (the default state after plugin installation), the path traversal protection can be bypassed, enabling deletion of arbitrary files including wp-config.php which can lead to complete site takeover via a fresh WordPress installation.

NVD CVE-2026-3141Wordfence advisoryCode change (fix)Plugin source

high 8.6 CVE-2026-22460 · published 2026-03-05

Path traversal / file read in FormGent (1.7.0 and older)

Affected
1.7.0 and older
Fixed in
1.8.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in wpWax FormGent formgent allows Path Traversal.This issue affects FormGent: from n/a through <= 1.7.0.

NVD CVE-2026-22460Patchstack advisory

critical 9.1 CVE-2025-10916 · published 2025-10-21

Arbitrary file deletion in FormGent (older than 1.0.4)

Affected
older than 1.0.4
Fixed in
1.0.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The FormGent WordPress plugin before 1.0.4 is vulnerable to arbitrary file deletion due to insufficient file path validation. This makes it possible for unauthenticated attackers to delete arbitrary files on the server.

NVD CVE-2025-10916WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FormGent vulnerability status badge
<a href="https://laskyr.com/plugins/formgent"><img src="https://laskyr.com/plugins/formgent/badge.svg" alt="FormGent vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit