Skip to content
Laskyr

Plugins · formfacade · data as of 2026-11-04

Is FormFacade safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0)

As of 2026-11-04. 5 issues are on record for older versions; version 2.0 or newer fixes all of them that state a fix.

Latest version
2.0
Last updated
2026-07-02
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Embed Google Forms™ in your wordpress site — by manidoraisamy

What to do

  1. Update to the latest version (2.0). Anything older than 2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get formfacade --field=version shows what you run; wp plugin update formfacade updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-62133 · published 2025-12-31

Cross-site request forgery (CSRF) in FormFacade (1.4.1 and older)

Affected
1.4.1 and older
Fixed in
2.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in manidoraisamy FormFacade formfacade allows Cross Site Request Forgery.This issue affects FormFacade: from n/a through <= 1.4.1.

NVD CVE-2025-62133Patchstack advisory

medium 6.1 CVE-2024-54301 · published 2024-12-13

Reflected cross-site scripting (XSS) in FormFacade (1.3.6 and older)

Affected
1.3.6 and older
Fixed in
1.3.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in manidoraisamy FormFacade formfacade allows Reflected XSS.This issue affects FormFacade: from n/a through <= 1.3.6.

NVD CVE-2024-54301Patchstack advisory

medium 6.1 CVE-2024-9613 · published 2024-10-26

Reflected cross-site scripting (XSS) in FormFacade (1.3.6 and older)

Affected
1.3.6 and older
Fixed in
1.3.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The FormFacade – WordPress plugin for Google Forms plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'userId' and 'publishId' parameters in all versions up to, and including, 1.3.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9613Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2024-43313 · published 2024-08-18

Reflected cross-site scripting (XSS) in FormFacade (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in manidoraisamy FormFacade formfacade allows Reflected XSS.This issue affects FormFacade: from n/a through <= 1.3.2.

NVD CVE-2024-43313Patchstack advisory

medium 5.4 CVE-2024-25934 · published 2024-03-15

Stored cross-site scripting (XSS) in FormFacade (1.0.0 and older)

Affected
1.0.0 and older
Fixed in
1.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in FormFacade allows Stored XSS.This issue affects FormFacade: from n/a through 1.0.0.

NVD CVE-2024-25934Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FormFacade vulnerability status badge
<a href="https://laskyr.com/plugins/formfacade"><img src="https://laskyr.com/plugins/formfacade/badge.svg" alt="FormFacade vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit