Plugins · form-vibes · data as of 2026-11-04
Is Form Vibes safe? Known vulnerabilities and latest version
- Latest version
- 1.5.3
- Last updated
- 2026-07-08
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 8.0+
Save Contact Form 7, Elementor, WPForms & Gravity Forms entries in database. View, filter, export form submissions to CSV & analytics reports. — by WPVibes
What to do
- Update to the latest version (1.5.3). Anything older than 1.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get form-vibes --field=version shows what you run; wp plugin update form-vibes updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-61947 · published 2026-07-23
Cross-site scripting (XSS) in Form Vibes (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- 1.5.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Form Vibes – Database Manager for Forms <= 1.5.2 versions.
high 7.2 CVE-2026-13378 · published 2026-07-11
Stored cross-site scripting (XSS) in Form Vibes (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- 1.5.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Form Vibes – Database Manager for Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Contact Form 7 Form Field in all versions up to, and including, 1.5.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-13378Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2025-13409 · published 2026-01-06
SQL injection in Form Vibes (1.4.13 and older)
- Affected
- 1.4.13 and older
- Fixed in
- 1.5 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Form Vibes – Database Manager for Forms plugin for WordPress is vulnerable to SQL Injection via the 'params' parameter in all versions up to, and including, 1.4.13 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2025-13409Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-5309 · published 2024-09-05
Missing authorization check in Form Vibes (1.4.12 and older)
- Affected
- 1.4.12 and older
- Fixed in
- 1.4.13 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Form Vibes – Database Manager for Forms plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to a missing capability check on the fv_export_csv, reset_settings, save_settings, save_columns_settings, get_analytics_data, get_event_logs_data, delete_submissions, and get_submissions functions in all versions up to, and including, 1.4.12. This makes it possible for authenticated attackers, with Subscriber-level access and above, to perform multiple unauthorized actions. NOTE: This vulnerability is partially fixed in version 1.4.12.
medium 6.5 CVE-2024-5325 · published 2024-07-12
SQL injection in Form Vibes (1.4.10 and older)
- Affected
- 1.4.10 and older
- Fixed in
- 1.4.11 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Form Vibes plugin for WordPress is vulnerable to SQL Injection via the ‘fv_export_data’ parameter in all versions up to, and including, 1.4.10 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
high 7.2 CVE-2022-3764 · published 2024-01-16
SQL injection in Form Vibes (older than 1.4.6)
- Affected
- older than 1.4.6
- Fixed in
- 1.4.6
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The plugin does not filter the "delete_entries" parameter from user requests, leading to an SQL Injection vulnerability.
Recent activity
- 2026-07-08 — latest release on wordpress.org (1.5.3).
- 2026-07-23 — Cross-site scripting (XSS) disclosed (CVE-2026-61947), fixed in 1.5.3.
- 2026-07-11 — Stored cross-site scripting (XSS) disclosed (CVE-2026-13378), fixed in 1.5.3.
- 2026-01-06 — SQL injection disclosed (CVE-2025-13409), fixed in 1.5.
Get an email when Form Vibes has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Form Vibes (form-vibes) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPVibes (4 tracked)
Types found in this plugin: SQL injection (3) · Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/form-vibes (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/form-vibes"><img src="https://laskyr.com/plugins/form-vibes/badge.svg" alt="Form Vibes vulnerability status"></a>