Skip to content
Laskyr

Plugins · form-block · data as of 2026-11-04

Is Form Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.2)

As of 2026-11-04. 3 issues are on record for older versions; version 1.8.2 or newer fixes all of them that state a fix.

Latest version
1.8.2
Last updated
2026-10-02
Active installs
300+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

An extensive yet user-friendly form block. — by epiphyt

What to do

  1. Update to the latest version (1.8.2). Anything older than 1.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get form-block --field=version shows what you run; wp plugin update form-block updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-104814 · published 2026-10-06

Cross-site scripting (XSS) in Form Block (1.8.1 and older)

Affected
1.8.1 and older
Fixed in
1.8.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Form Block <= 1.8.1 versions.

NVD CVE-2026-104814Patchstack advisory

critical 9.0 CVE-2025-54693 · published 2025-08-14

Arbitrary file upload in Form Block (1.5.5 and older)

Affected
1.5.5 and older
Fixed in
1.5.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in epiphyt Form Block form-block allows Upload a Web Shell to a Web Server.This issue affects Form Block: from n/a through <= 1.5.5.

NVD CVE-2025-54693Patchstack advisory

medium 6.5 CVE-2023-30616 · published 2023-04-20

Cross-site request forgery (CSRF) in Form Block (older than 1.0.2)

Affected
older than 1.0.2
Fixed in
1.0.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Form block is a wordpress plugin designed to make form creation easier. Versions prior to 1.0.2 are subject to a Cross-Site Request Forgery due to a missing nonce check. There is potential for a Cross Site Request Forgery for all form blocks, since it allows to send requests to the forms from any website without a user noticing. Users are advised to upgrade to version 1.0.2. There are no known workarounds for this vulnerability.

NVD CVE-2023-30616github.comgithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Form Block vulnerability status badge
<a href="https://laskyr.com/plugins/form-block"><img src="https://laskyr.com/plugins/form-block/badge.svg" alt="Form Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit